[Problem] Windows 10 - Creators update = Easel driver no longer works

Installed Creators update and it if I click Carve it just repeatedly forces the Driver installation popup window.

CARVEY. LATEST VERSION OF EASEL.

Was working fine before the update.
Have uninstalled/reinstalled >3 times.
Hard power off & reboot all machines
Disconnected plugs from both Ports, laptop & carvey
Tried different Port on USB
Tried Chrome and Edge

Running check.bat automatically closes the command prompt within seconds. No error message displayed.
No data at all ln error log.
It is zero bytes and I cannot attach it.

Same problem here after the creator update. Have tried re-installing the drivers, removing device, scanning for hardware changes etc. Stange thing is, that Carvey shows as device when checking installed printers. So the USB connection seems to be working, but Easel does not see the machine. Tried Universal G-code sender too, but no joy. Any suggestions? My other CNC machines running on MACH 4 work fine after the update.

I tried my Wifes laptop that isn’t updated and it worked fine. Have emailed their helpdesk and will update post when able

Good to hear! On my MacBook, Carvey also works. Just an issue after the Windows 10 Creator update.

Great success comrades! Magnificent Support has destroyed this issue with an updated driver they gave me for testing

Hi @RobbieMacgillivray, @NicoBerx, and anyone else having Easel repeatedly tell you you need to install the driver after installing the Windows 10 Creators Update—

We’ve released a new version that fixes the installation problems on this version of Windows. Please go to http://easel.inventables.com/downloads and download version 0.3.5 (or newer, for anyone from the future).

Sorry for the trouble!

Thanks a million! Great job, and very fast! . Carvey is working on Windows 10 after the Creator update!