Question about UGS

I have been successfully using UGS but have had a couple of minor bugs?

1 - At the end of a file it never stops sending. I just sits there in sending until I hit the “Cancel” button.
Then sometimes it gives me a “File Complete” sometimes it gives me a “File Complete with Error” and goes into alarm mode. Sometimes it still just sits there to I do a soft reset. and then one of the messages will pop up.

Is this normal for UGS?
Do I need to add some kind of end of file command to my g-code?
I tried adding a “$” at the end but that seemed to have no effect.

2 - Does UGS have a max file size? I tried loading a large cut file and it would sit forever “opening” then give up going back to “Brows” as if I never selected a file. (I wound up splitting the file into 2 smaller files and they loaded fine)
Do I need to increase a memory size setting somewhere?

Any input would be appreciated.

The latest version of grbl takes care of the issue. Early releases of 0.9i had a bug that got fixed a couple months ago.

1 Like

I’ve had odd post-carve issues with UGS also. Is there a way to determine if the version of 0.9i I have is the bad one?

Maybe your post processor have something missing. Which program you’re using to build tool path. V-Carve/Meshcam…?

At the end of a run i simply hit pause and resume from the machine tab and it gives me a job completed window with elapsed time.

I have gooten accustomed to doing it this way so I find it to be no biggie.

VCarve Pro
I checked the post processor and it is putting the end of file “M30”
It sounds like it is a UGS issue.

I will give that a try. :smile:

I believe it was a known issue with earlier versions of .9i, which I think would have included the branch that the X-Carve shipped with. I upgraded mine to a later version of .9i and it fixed the problem.

1 Like

UGS does start behaving badly with very large files (over 200,000 lines). Not opening the visualizer window will allow you to run larger files. It appears that UGS does load the entire file into memory so large files can cause the program to stop or lockup.

1 Like

yeah hit pause and then resume and it will end the run. however be aware it will switch the units from inches to metric. youll see your machine coordinates jump to from 0,0 to some crazy metric nonsense. youll need to either reset your machine coordinates before running another file or enter the command switching it back to inches and telling the machine you are at x0 y0 and where ever your z is

or just upgrade your grbl lol

Ah, that may explain a different issue I am having. A slight shift between the rough cut and the final pass.
I thought I had knocked something out of alignment changing the bit. ;/

Is the link on this page the correct one for the updated version?

It looks like 0.9j is available here: https://github.com/inventables/grbl should we be using that one??

Since that has the official Inventables branding, I imagine you’ll be fine installing it.

Ugh well no joy.
I updated the hex file using Xloader
Now I just get “GRBL has not finished booting” errors

I tried to follow the instructions for ArduinoIDE program (successfully running EEPROM_clear) but it won’t compile / upload GrblUpload
“grblUpload.ino:27:18: fatal error: grbl.h: No such file or directory”

Yeah, let me see if I can find my original post when I upgraded my firmware, I think the instructions were just slightly off regarding a directory or something.

[edit] hmm, well, I found the post I was looking for, but I didn’t write up the directions in it, sorry. But I did stick that error into Google and I think that this will help, it sounds like what I had to do to get it to work:

Are you doing this, some lines must be changed on eeprom_clear;

Open the Arduino IDE

Go to File - Examples - EEPROM - eeprom_clear
Click it,

Find this line,

for ( int i = 0 ; i < EEPROM.length() ; i++ )

MUST BE CHANGED TO

for ( int i = 0 ; i < 1024; i++ )

After upload finish, close Arduino IDE, open XLoader , Make sure all your settings are correct
Device = Uno(ATmega328)
Baud rate 115200
Load HEX file

Close XLoader and start Easel, run machine setup

I will give this a try

Thanks, I figured I was missing a step or had something configured wrong.

Does anyone know if there is a pre-compiled 0.9j HEX around with Inventables’ seal of approval. I would think that would be something they would want to stay on top of.

They have on on their page here.
https://inventables.desk.com/customer/portal/articles/2069033-grbl

1 Like