[Solved - Elec. Interference] - Job keeps failing in easel

I’ve done about a dozen carves so far, max about 4 hours. Any failures could be identified and chalked up to learning curve to this point. This evening I felt I was ready to try my first paying job. Put on a chunk of polycarve and got the job complete message after carving one letter. I figured I did something wrong. Loaded a fresh chunk of material, doublechecked my settings and tried again. This time I carved one letter and got a layer or two deep on the second one - job complete message. Grumble grumble… grabbed a different job on the same material, flipped that piece over and tried again - letter and a half in and we’re supposedly complete again.

If it means anything, spindle isn’t shutting off and it’s not returning to home position when the job complete message pops. I have the ac controller that people in the forums suggest for the spindle. Same computer I started with, nothing has intentionally been changed.

Any suggestions?

Electrical noise,

Separate signal wires and power wires, if they mesh run them perpendicular to eah other.
Noise can also come from the spindle motor,

I have on my system experienced stopping dead in its tracks while Easel prompt “Finished, happy or not?” (Easel / Arduino/GShield, rest is DIY)
The green Carve button in Easel turn blue for a couple of seconds before returning to green state (indicating that USB drop out and controller board reset (and think its at x0,y0,z0)
Other occations spindle return to original zero, meaning USB connection was NOT lost since it has retained valid zero.

Have by now almost reduced my dropouts completely by:

  • ruining a few blanks during testing
  • Separating the signal/power wires (Increased distance)
  • Shielded USB cable
  • Dropping spindle speed (Makita RT700 used, setting 1-3work fine for me)
    Motor brushes arc differently at different speeds. A break-in run to make them seat properly might reduce amount/intensity of the arcing.

I have the x-controller. I didn’t notice if the easel button was turning blue, I’ll look tonight if it happens again. I have a shielded USB cable I could try. Dewalt 611 is currently on 1 per Phil, I’ll turn it up and see what happens.

It’s my first time carving poly. Do some materials create static electricity, and can that have an effect on the controller?

1 Like

It sounds to me like your bit is too large to make the cuts you need. I would remove the bit and do a dry run with the spindle turned off to see how far it gets and then tell easel you are using a bit half the size and do another dry run to see if it would “cut” the entire project.

ok guys.
I have an Xcarve on order, but it hasn’t shipped yet.
I see everyone talking about Easel and the problems that you all have.
I ordered the machine with the Vectric desktop software because I have no internet in my shop and I do not want to be tied to the internet in any way.
So the question becomes, is it a must that I use Easel and or use the internet to run my machine?
If I need Easel, or I need to be connected to the internet in any way, then I have no choice but to cancel my order.

No problem at all, you can use the X-Carve without an internet connection if you use Vcarve and and Gcode sender like the Universal Gcode Sender.

how would too large of a bit cause the machine to stop? I’ve already seen instances where it will skip portions of a carve where the path is too narrow for the bit. If that’s what you are referring to, yesterdays attempt was 2" block letters wit ha 1/16" bit, only because I need crisp corners. There’s no way the bit is skipping the remaining 17 letters because paths are too narrrow.

As for the requirement for easel - I’ll throw in my 2 cents because I’m typing. Anything that will generate gcode can be sent to the machine using something like universal gcode sender, but it has it’s share of problems from time to time as well. I haven’t played with the vectric software, so I don’t know if it interfaces directly with the xcarve or not. If it does it’s on my short list, but I don’t think my issues at the moment are software related - not easel anyway

When Easel says the job is complete before everything is cut is usually caused by Easel “thinking” it has cut everything that can be cut with the bit you told it was loaded. I have seen Easel get confused and decide that some toolpaths needed a much smaller tool than seemed necessary. Try a dry cut with a smaller tool and see what happens, if it still stops prematurly then you obviously have a different problem.

strokes on most of the letters were 5/8" wide or more. I can’t see it being the issue, but I’ll give it a shot

Static buildup cannot travel from the bit to your electronics. It will be dissipated by the router or through the frame of the x-carve if you have the spindle.

Also try to use a V-bit for testing. You can cut just about any size project with them.
Phil Maybe you can get him a file to test that you know works fine. I am at work cannot make one right now.

Kinda figured as much on the static, but when new material = new problems ya gotta ask the dumb questions. I’ll try one of the files I cut out of pine - I have several saved files that worked fine.

1 Like

Thanks Phil.
We owe you one.

1 Like

I don’t even have my X-Carve put together yet and I already feel like I owe Phil more than one!


Thanks for the input everybody - turns out it was electrical noise, but not from anything on the machine. I carved four of the remaining five signs today without incident. One of the kids came out to watch as I was setting up for number 5, and said they were cold. I turned on the wall furnace and poof - no connection. Turned it off and power cycled the x-controller, then intentionally turned it back on - instant disconnect. I’ve had it running the last couple times I was in the workshop, and every time I had issues. Just wasn’t smart enough to put it together I guess.

I’ve got a bunch of ferrite cores at the shop - I’ll start by putting those around power leads to see if it helps. Maybe this winter I’ll have to carve in the cold…


Great to hear! Yes indeed, electrical noise can come from elsewhere both inside and outside of current household.
During peak hours during the day the grid in some places are taxed higher and can cause anomalies, so if users experience more problems during specific hrs during the day there could be a “dirty” appliance running.

Glad to hear you sorted it out! :slight_smile:

You must be using a 2.4 Ghz router (b,g,n). The microwave operates very close the 2.4 Ghz frequency. The easy solution is to just get a dual band router (most routers now are dual band) that has a 5 Ghz band for a and n.

1 Like

Check to see if they are making you pay rent for it, if so spend $60 and buy your own and stop paying the $10 per month for it.

1 Like

Phil - re: the microwave. That shouldn’t happen. It’s possible that there could be line noise, but if the microwave magnetron is operating near 2.4ghz and it’s knocking out wifi, I would be concerned about RF “leakage” from the unit. Here’s a stupid test - put your cell phone in the microwave and call it. If it rings, it’s time for a new microwave.

Oh, and if the cable company happens to be Charter, you can buy your own router but you still need to rent the modem. Check with provider BEFORE you buy

Hi glad you got something sorted,

my experience with noise is once i start a job in the shed i cannot turn lights on or off, I have big old fluro lights and on/off will stop machine dead in its tracks everytime,

Not a good test. The microwave case is designed to block, (or limit), a specific RF frequency from leaking out. This includes the aperture of the metal screen behind the door glass. Cell phones operate on a different frequency which will most likely pass right through the microwave’s case.