SOLVED Lost grbl settings

I just had some trouble with ugs, it wouldn’t unlock. So i manualy changed $22 in the machine inspector (easel) (and changed it back).

Now i can unlock the machine in ugs, but the xaxis moves very rapid and way far (50mm+ instead of 10mm).
as you can see in the picture, the settings are changed.

Is there a way to change them manualy? or do i need to flash the arduino?

If it is a Inventables gshield, you can issue a “$RST=$” in the console window in machine inspector. This should put it back to defaults. See

this doesn’t work in the machine inspector, is there an other way to open and change the grbl settings?

I should have said, remove the quotes. Did you ?

yes, i removed the quotes.

it says bad number format

Use the serial monitor in the Arduino IDE. It should pass that command ok.

What’s your version of grbl ? I flashed mine from source, I didn’t buy from Inventables, but the command worked fine when I did it on mine.

The $RST=$ doesent work, maybe i have to reflash the arduino?

i am not a very skilled computer guy, so if someone can explane it step by step i would be very thankfull.

It looks like the command works, but possible that some of the variables are corrupted. The $22 to $27 variables shouldn’t have those extra garbage characters. Try just setting those to zero, and then to the correct value. I thing it is because of those that’s it’s printing the error:Bad number format.

This feature was added in 0.9j. You have 0.9i. Look in your screenshot: Grbl 0.9i $ for help
This is why the RST feature will not work.

Hopefully you can figure out how to [reflash][1] the Arduino with the [latest GRBL code][2].

Then set the EEPROM to defaults and try again.

You need to use the Inventables fork of the grbl code. Here:

I did reflash the arduino wit Grbl 0.9J, it wasn’t so hard after all. But my Y axis doesn’t move like it supposed to move, when i move it in easel 1mm, in reality it moves 4-5mm.

When i start the arduino all 3 lights are green until i send a command, than the y axis light turns off, and only turns on when i send a command.

Did you do a reset after the flash ? what are the new values for the settings ?

This is not necessarily an indication of a problem. The green LEDs turn on and off as the X-carve works.

Whether the LED is on or off depends on which direction the current flows through one of the stepper motor windings. So, depending on the direction of movement the LED may be on or off.

Do post your new $$ output.

Ok, that looks good.

Right now the problem is that the Y axis doesn’t move the correct amount. Is there any other problem at this time?

The problem with the Y axis is the only problem, the x and z axis move correctly. I have checked all the electric connections, V-wheels and belt tension.

Did you have / know how to use a voltmeter?

i have, if you can tell me where i should see what voltage i’m off the the garage :grin:


Looking at the picture and your gShield from the edge that has the homing switch connector, the D8 through D13 etc. positions are where you soldered the pins for the homing switches and the spindle control. Not interested in those at the moment.

The set of holes to the left of that which has D2 through D5 labeled is what we want to look at. Just to the right of the D5 hole is D6. This is the direction signal for the Y axis.

When you jog your machine in one direction that pin will measure about 0 volts with respect to ground. When you jog the machine the other direction then you should read about 5 volts on that position.

D3 is the step pulse signal for the Y axis. When your machine is not moving this hole should be about 0 volts. When you jog the Y axis this pin will have a square wave on it and the meter should show something like 70 mV as an average.

Taking these measurements will tell you if the Arduino is trying to tell the motor to move.

Check that and then report the results.