[SOLVED] - X-Carve Controller - Not Connecting

Hi All - I have been working on getting my x-carve up and running the last couple of days. I am currently stuck in getting easel to connect to the x-carve. Here is what i have done so far.

What i am currently hearing is a Tick/Tock on the Z-Axis while the X-Carve is trying to connect when i disconnect usb this tick tock on all three machines easel is showing up in Device Manager under ports USB SERIAL (PORT 3)

  1. Tried 3x Laptops (1 Dell Win 7, 1 Dell Win 10, 1 Lenovo Win 10)
    On each of the laptops we have done the following
  • Browser (Chrome, Firefox)
    Disabled all network security and have listed my home ip as private
    Tried all usb ports in each of the computers.

On X-Carve Controller
Removed USB Hub and went direct line into laptop
Checked wiring

One question that i have is what should show when X-Carve Controller show int he device manager? should it be USB Port?

Thank you for your help in advance, Unfortunately i haven’t been able to connect with the team at x-carve due to my work schedule this week and this seems to be my only option.

Have you installed the FTDI drivers? That’s the most important step.

Is the LED turning on?

Hi Justin thanks for the quick reply, I should have mentioned that in my post Yes on each of the computers i have gone through and also installed the FTDI Divers on the front of the x-carve i am also seeing a green light . Thanks for any help our this community could help with!!



What is odd is that when i plug in each of the laptops i do here a stepper motor turn off / turn on but nothing is seeming to connect… thanks for any help again

Most likely, no.

In your example of HAM radio, when you are transmitting into an open it causes like 100% reverse power so if you’re outputting 1 kW, the amp sees about 1kW back into it. Based on the Google search I did, the same phenomenon occurs on tube amps but not solid state amps. It’s apparently a high voltage/low current versus low voltage/high current thing.

So, I believe that the drivers, given they are low voltage and high current (solid state) would not have the same issue.

As for the original issue, you may want to try flashing the Xcontroller firmware to see if that helps. I can’t seem to find the particular page I was looking for to help but there is plenty of info out there. The Xcontroller needs 1.0c or 1.1f on it.

1 Like

Thanks guys I will give that a go and report back in the morning!!

No, you can run the drivers with no motors connected without issue. And don’t get us going on the moving by hand thing again.
What you do not want to do is connect or disconnect your steppers while the drivers are powered.

I haven’t been able to update the firmware on my x-controller because i am concerned of what version is already on the x-carve. Is there a way for me to get this information for an application? If its possible i’d like to first make sure my setup is good is there another application i can use to verify that the controller is working properly. If anyone could share some tips or what they are seeing in the device manager when their x-carve is connected would be very helpful.


You would be able to see it in Easel but not if you can’t connect.

Is there something like a Makerbot or other device that could be grabbing the port?

Without the hub, you’re still seeing USB SERIAL in devices?
You could use something like the Arduino IDE to grab the version if it’s just an Easel thing, but I think it’s more likely that there’s an issue with drivers. Maybe uninstall the driver and reinstall?

I currently don’t have any other application installed that would be grabbing the USB i am going to uninstall / restart and install the latest version of easel local on my machine as an administrator to see if there is a change. Any other thoughts that i can try? In Arduinio IDE what should i select as my Arduinio type ?

Thanks all for your help! This community forum rocks!!

It actually doesn’t matter for just connecting to the Serial Monitor. You’re just using the Arduino IDE as a way to see the serial responses. Baud rate should be 115200.

Hi Thanks Neil for firing a quick response back i am not very familiar with Arduino but from what i can see i see no data happening on the Serial port on start up. Attaching some pngs for reference of what i am seeing in the ide as well as device manager after installing the drivers as well as updating the FTDI driver and restarting.

I misread your original post. Are you sure the USB SERIAL is your x-carve? What are you seeing in “devices and printers”? Do you hear the little USB plugged in sound?

Most definitely usb serial port 5 is the x-carve. I plug in and hear the USB Sound within windows the usb serial shows up i unplug and am also seeing the serial port disappear. I do not have any other usb related items plugged into this laptop and have even taken out my usb mouse thinking it could be power related.

Did you try uninstalling and reinstalling the driver?

yes I have installed / reinstalled the drivers for easel as well as the FTDI driver on the 3 machines I have access to each machine reports usb serial port upon connecting to the device manager

Are you sure the x-controller has power? Other than USB.
Check the emergency stop.

Yes the controller has power, when hitting the emergency stop the power is cut and usb Serial no longer shows in DM.

Upon pullng up on the emergency stop I again see usb serial show and green power light on xcarve is on

In my first post I mentioned that when I go into easel for setup I can here the a click on off roughly every 5 seconds, while I am waiting for the xcarve to connect. When I close out of the browser this click on and off stops.

Are you able to see the x-carve controller in your DM and can you send some screens so I can compare ?