[Solved] X-carve not connecting to Easel --> Fixed by temporarily uninstalling antivirus software

I put my X-Carve together last weekend and started setting it up this week. I went through the setup steps, installed the Arduino drivers and software and then downloaded and installed Easel Local.

When I returned to Easel after my laptop restarted, I still getthe download Easel Local screen when I click on “Set up your machine”. I’ve tried this on 2 laptops w/ Arduino and Easel Local installed on both and get the same results.

As far as I can tell, everything is wired up correctly… the spindle kicks on when I flip the switch up, the Arduino lights up when connected to USB and shows up as Ardunio Uno (com3) in ‘Devices and Printers’. The LEDS for each axis light up and the X-carve resists manual movement.

Did I miss something? Is there a way to check that grbl is installed correctly on the Arduino?

@ChristopherJones sorry you are having trouble. To diagnose it I have a few questions:

  1. Do you have multiple tabs in Easel open?
  2. Is there some other software that could be grabbing the connection to the Arduino? Is the IDE open?

Single tab of Easel open in Chrome (tried Firefox and Internet Explorer as well).
No other software or hardware currently connected or using Arduino.
Ardruino IDE is not open (and has never been opened)

@ChristopherJones - It looks like the browser checks your local machine for the install, and it is not seeing whatever file(s) it is looking for. Do you have administrator rights on this machine as the user you are using during the install? Do you see the local install on your machine? Do you have a C:\EaselLocal folder?

Yes, I have admin rights on my laptops. Here are my easel local files

@ChristopherJones - OK, it is a problem somehow between the browser and the local install. You’re not even getting to the point where the X-Carve and Arduino/Grbl matter. The browser is not seeing your local install, or the local install is not finding the information it needs for some reason, so the website keeps telling you to install it again. You don’t have anything (browser, Operating System, etc) installed on any drive letter other than C: do you?

@ChristopherJones - Go to task manager (If running Windows 7 hit CTRL+ALT+DEL and choose Start Task Manager) then click the Services tab, and see if you see EaselLocal running as a Service. If not, see if it is listed as a service, and if so, start it manually.

1 Like

EaselLocal is running

@ChristopherJones - OK, just trying to eliminate all the possibilities. Have you changed any of the security settings in your browser(s)? I have very little idea how the Easel service works, but if the browser doesn’t trust the zone the website is in, it may be blocking it from talking to the local machine. Easel works for most people, so there is probably some small difference on your end that is blocking something somewhere. Browser settings, firewall, ISP, etc… Is there any way you can try a different ISP (friend’s house, work, etc) just to see if that makes any difference? I see you said you tried more than 1 laptop. Maybe try resetting Chrome on one of them back to all defaults to see if that makes any difference. Is there anything that you can think of that might not be 100% default/standard on those machines or in your connection to the internet? Proxy, etc.? Could it be your Antivirus software or other protection running? When I disable the EaselLocal service, I get the same message you are getting, so something is keeping the website from seeing the local service as running.

It’s definitely a problem on my end. I just installed easel local on a 3rd computer (my upstairs desktop) and it worked!
Unfortunately it’s no where near my x-carve.

I will look further into the security settings on my basement laptop and if all else fails, I’ll be moving the desktop to the basement.

@ChristopherJones - The good news is you now have one that works that you can use as a comparison to see what is different. Good luck, and happy carving!

@ChristopherJones can you post back:

  1. What versions of Windows you are running on each machine?

  2. What browser versions are you running?

Win 7 64 bit on all.
Chrome on all.

Do you know of anything different on the one that works compared to the 2 that don’t?

I don’t yet, but I’m going to try to figure out what is causing the block. The 2 laptops are older (3+ years) The desktop is new, but not the system I want to use for the X-carve.

Are there different builds or different version numbers of Windows 7 on the old ones vs. the new one?

In Chrome can you find the version number on each of the 3 machines?

A mention of laptops not connecting but the desktop does, my guess (and I am an amateur at this) is that the laptops have been set to “public networks”, this happens if you use the laptops in public and don’t want anyone “seeing” you machine on their network.

Try changing you connection settings to “Private Network” in Control Panel/Network Connections

im having the same problem with mine but mines an S2. Maybe a new download will come out soon with the proper drivers for S1 and S2. It seems easel is now promoting Xcarve and forgetting about shapeoko It sucks, because i really liked easel. time to move and find something else

All 3 are Chrome version 43.0.2357.124 m. I have tried with other browsers with the same results.

I briefly saw this screeen (see below) today using my work laptop, but when I checked again, it was back to the original ‘download easel local’ screen.