Stepper motor upgrade

Yeah, that one will suffice :slight_smile:

Thank’s Haldor, I could not get that power supply, I had trouble placing the order, website problem, so I got this one instead it has the same spec. and it is local here in the UK
48v 400w 8.3 amp----https://www.ebay.co.uk/itm/Regulated-Switching-Power-Supply-3-3V-5V-9V-12V-18V-24V-36V-48V-Universal-PSU-DC/151886747221?ssPageName=STRK%3AMEBIDX%3AIT&var=451789499656&_trksid=p2060353.m2749.l2649

Haldor, do you have any pictures of the finished controller, inside and outside, I am waiting for parts to be delivered, I am looking for ideas on fitting switches and a fan, emergency stop and whatever else is needed

I have been away for a funeral - I’ll see what I can accomodate :slight_smile:
Its however not finished as its been put to use haha :wink:

1 Like

Thank you

I have been looking for wiring diagrams to wire up 4 stepper motor drivers, all I seem to find are for 3 drivers like this one, https://www.youtube.com/watch?v=BZH1WkgfOug which is a help but I am not sure what pins on the Arduino to use for the fourth driver, has anyone else done this

4th driver as in a slaved stepper, for like Y-axis?
If so, simply provide the same signal to the 4th driver, making a Y-split.

Thank’s Haldor, I have been following your build, and on the first photo you have the Arduino wired up --pins 2-7 and 8-13 in 2 groups of 6 wires, making 12 pins used, but there are only 11 wires going to the terminal block, where is the missing wire, have you finished yours yet, I have all the parts now and ready to wire up, just hoping you will post some more photos of your build, it has been a great help


I was going to set the current table to RMS 3.1 and the Pulse/Rev to 800 which I think is half step, I have been reading as much as I can on this, but I am not 100% sure, my motors are Nema 23 3.1Nm 1.8

Set RMS value to approx 70% of the rated max amp for your stepper.
If its 3A set to 2.1A

800step = 1/4 step (as your stepper have 200 step per revolution as fullstep)
I run mine at half step (400) but thats not the only “correct” value either :slight_smile:

Thank’s Haldor, I want to run at half step so I will set that to (400) and leave SW4 switched off
the stepper motor is 4.2 A so 3.1 A is pretty close to 70% of that, next one down is 2.7A

If amps are set too high the only clue will be stepper heat, as long as it dont heat up past 80degC there is no real danger for harm. Less is more comforting, but know that steppers do not mind some heat at all, just not too much :slight_smile:
If operated too hot the magnets inside will change strength and affect performance.

If you can place your palm firmly on the motor case and hold for approx 3s the case temp is about 55degC and well within both personal and hardware comfort :slight_smile:

Thank’s Haldor, the more information I have the better, I will check for heat when they are working, it’s good to know about the magnets inside

I have been doing the wiring slowly, when I plugged in yesterday all four green lights on the drivers came on so I have done some more wiring and this morning only one green light came on and another was green and red and two with no lights, I have gone back to the start again but can’t get any lights to come on now, have I damaged the drivers, I did expect a bit of trouble but not this much, I have been trying for hours and I think I need help with this

I can only suggest that you disconnect all drivers and focus on one axis at the time.

Start with X, get it to light green, operate / move.
Then do the same for Z and finally Y.

The controller do not care if some axis are not connected.

Thank’s Haldor, I stripped everything down and tried the drivers one at a time, just the power supply and driver, 3 worked, well at least the green light came on the 4 one did not ( bloody Chinese) I will get in touch with them, but even if they offer to replace it it’s going to take a month to get here, I don’t trust them now

You can run both Y´s from one driver, just increase RMS current limit a little.

They are sending me a new driver, which is good, as it did light up in the first place I think it may have been my fault, I am not sure, anyway, I can try running the two Y’s from one driver, for now, I have been trying to wire up one at a time this morning starting with the X, I have got GRBL installed on the Arduino, and it is connecting to the port okay when I turn the power on the stepper motor just takes one step left then one step right, is this a wiring problem or GRBL problem,

When power is OFF the stepper will come to rest at an arbitrary rotor position, when power ON it will “jolt / lock” to nearest “pole”

Will it jog?

No it will not jog it just clicks left and right every 4 seconds, when the power is on it locks as usual but I can still turn the screw by hand, it’s fairly hard to turn but I can do it