Inventables Community Forum

Stop during work

Hello
I have a problem stopping work
I started by changing the USB cable, then the internet by wire
And he stops work
What could be the reason I will add that I did this project in the air without the spindle turned on
I have GRBL 1.1e on an ardiuno uno plate

You are getting GRBL errors 8 and 20. Here is the meaning of these errors:

Error 8: Grbl ‘$’ command cannot be used unless Grbl is IDLE. Ensures smooth operation during a job.

Error 20: Unsupported or invalid g-code command found in block.

So something on the g-code you are trying to send has a command that GRBL does not support.

You should look at the console output just before the errors and see what command was sent, Then you would have to determine whether it is supported by GRBL or not. Another question would be how did the g-code get generated, by what program. Was it Easel, if so you should contact Inventables and ask them to figure out why that code was generated.

Hope that helps.

1 Like

Just to be sure I understood right: you had the project completed in an air cut, buit when cutting into material the cut randomly stops?
My thoughts would be: If your cut completes in an air cut it shouldn’t be your gcode. If it stops under load randomly, it sound to me like interference. Have a look here, where I summarized my experience with that.

Another question: How many hours to you have on your router? Are your brushes ok?

2 Likes

And what exactly does IDLE mean? And how to fix it?
He stops even while carving some icon with easela

No, it doesn’t even stop in the air
And with the spindle off

And the disappearance of the Internet can cause a break in work?

So short recap:

  • You cut the whole projects with your router off, just in the air. The projects “completes” = runs to the end.
  • You cut the whole projects with your router on, in material. The projects does not complete and stops. Does it stop always at the same position?

My best guess is that you have electronic interference. Have a look at some posts in the forum, there have been quite a lot people with that problem. If I was in your position, I would try some of the easy and cheap stuff (USB hub, bypass USB bulkhead, check router brushes, etc.) in my previously linked post and see if that can fix your problem.

1 Like

interrupts work in the air, stops working in the air
The spindle does not work, it is not turned on
And stops in different places
What does this hub look like?

Untitled.nc (609.3 KB)
Please, gentlemen, check this file at home, are there any errors?

Yes, thats an USB hub I was talking about. It’s important, that it’s externally powered (this one is). If your carve stops while the spindle is off the router brushes aren’t your problem. I would try the following things first:

  • USB hub
  • bypass USB bulkhead on x controller
  • check energy settings on your pc (no sleep mode etc., make sure you get the USB energy settings too)
1 Like

I will do well as you say thank you for the suggestions
Yesterday I tried to export g-code to grblcontrol and I get the same 20 error
Does this mean the wrong g-code?
How to check it before carving is it correct?

GRBL supports the M7 command, it is used to control coolant.

Perhaps grblControl does not support it. You could try another g-code sender like UGS, which is also free and many of us use it on a regular basis. You can download it here:

http://winder.github.io/ugs_website/download/

I downloaded this program and gets the same errors

How did you generate the code in the first place?

You can edit the code file and just remove the line with the M7 command and run your program again. Gcode files are just text files and do not require any special editors.

Do you use coolant?

Also you could post your file here and we can look at it, maybe there are some extra character in the file around the M7 command that make it look as unsupported to the senders.

1 Like

I generated G-code in easel from available fonts and icons
I don’t use coolant
how can you remove this item in grbl?
I’m sending a file Untitled (1).nc (842.7 KB)
Thank you very much for your help

Easel only generates M7 and M8 commands if you have “Accessory Commands” enabled in the Advanced settings.

Make sure you don’t have that option selected.

If you already don’t have it selected and Easel still generates the M7 command for your project you should contact Inventables and report a bug.

1 Like

Yes, I had these functions marked
Error 20 is no longer displayed to me
But the machine still stops
And it displays error 8 again