Stuck at "Starting homing sequence..." with easel

Hello, I can manually move all three axis in easel setup. They seem to move in the correct directions.
When the machine setup procedure enters the homing sequence it sticks at “Starting homing sequence”

Any ideas?

I’m having the same issue. The x axis moves about 1/2" in the wrong direction and stops.

I’m dealing with a similar situation. I’ve gotten part of the way there by updating the software across the board (erase then re-flash the arduino, update the gshield code). Now, I’ve got the Z-axis homing correctly, and then, … absolutely nothing else happens. Everything locks up. Does anyone know what order the axes should perform the homing sequence in?

Most likely you are getting false triggers on your homing switches, or maybe a wiring issue.

Homing sequence is move Z to home, then move X and Y to home simultaneously.

Did you use shielded cable for your homing switches?


Just a clarification - the code that runs in the Arduino is grbl. The gShield does not have any code associated with it, it is a slave device for the Arduino and is controlled by grbl.

The easiest thing I can think is to power down, disconnect the homing switch cables connectors at the controller and ensure that the homing switch cables are NOT shorted at the cable on the controller end. The switches should be normally open when NOT engaged. If you don’t have a cheap meter they are like $5 at Harbor Freight. While you are at it make sure that the limit switches go to normally closed when engaged.

1 Like

OK. So the limit switches aren’t your problem. I should note for others… I bought a 10 pack of limit switches. On 4 of 10 switches if I tightened the attachment screws even to finger tight, the limit switch did not work. Something inside the switch was being compressed that stopped the switches from functioning. Just FYI.

Homing can be bypassed. This is why they sell the Xcarve with the option of adding the limit switches and not standard with the kit. I do not currently have operating switches, I have not taken the time to chase the ghosts down yet or to troubleshoot. The only crashes I have had were user error.

1 Like

all that have been doing is set work zero and all runs well unless “I” screw up …

1 Like


Turn on homing by setting $22=1

Make sure that $3 and $23 are the same value (default is 3). If your machine works right and they don’t match then make $23 the same value as $3

That should get you started.

When you get homing working I would recommend that you turn on soft limits ($20=1) and home your machine each time you start it up.

1 Like


Your grbl parameters look fine.

X homing D9, Y homing D10, Spindle PWM D11, Z homing D12

$130 ,$131, and $132 set the work space size for soft limits.

Do you have shielded wires for your homing switches?

Try this:

1 Like

A fix has been posted here - Entering a machine’s COM port manually

1 Like