Touch Plate not working

I have one wire to A5 pin on the arduino and another to the main power ground on the gshield. Both wires are attached to alligator clips to attach to the bit and the plate. When I run the G38.2 Z-.5 F2 command, I only get “Alarm: Probe fail” before any movement takes place. I have checked continuity and both wires are good with minimal resistance. I tested the voltage from the arduino at the plate and am getting approx. 4.9v. The bit is approx. 1/4" above the plate. I have tried running the command in several different conditions (clips hooked to each other, hooked to nothing, a5 wire removed from the arduino, different ground, etc.) and I still get the error. Does anyone have any thoughts/suggestions? It has never worked for me, so it’s probably something I’m doing. Thanks!


though im not sure why it would matter have you tried F1 for your speed?

also just to try to rule out some ideas,
is your homing turned on?
have you homed your machine before doing the probe?
are your wires to the touch plate running next to any other power source or wires?
you checked continuity of the wires, i take it that means you checked your ground?

I have not tried F1 (not sure what you want me to try…) yes, I have homed the machine first (and tried by overriding the lock and not homing) the wires to the touch plate are running out of the machine but on the opposite side of the power cord. They are running near the axis control wiring, so maybe there is some interference, although I’m not sure how to prevent that since the wires all come out of the same side. I made a loop through the multimeter by connecting the touch plate clip to the + and the ground to the - side and that gave me approx 4.9v (unless I’m not using my multimeter correctly, which is a possibility). I checked both the ground and the power (a5) wires by putting a probe where they attach to the arduino and clipping the end of the wire on the other probe and they ohm’d out at or near zero

BadWolf, great suggestions.
i’m new to X-Carve, (still in the setting up stages & therefore know that there is much more for me to learn & i’m excited to gain all these skills)… and although i’m not really helping w/ the answer (but i am keen to find out the resolution of this question) i’d like to know the advantage of using a touch plate as opposed to using something like the Easel’s Homing process.
Russ from Coral Springs, Fl.

on your command G38.2 Z-.5 F2 try it as G38.2 Z-.5 F1 this will just slow the speed rate down, which shouldnt matter as far as i know. only reason i suggest is that i use the F1 speed and know it works. just trying to eliminate any variables

i did a google search and found a few entries but nothing with any solutions. one said electrical noise interference may be causing the issue but there was no follow up whether a solution was found. thats why i suggested checking your wire routing.
another i saw said something about not getting the correct 5v from the A5 pin but youve measured 4.9 at the plate, i would think that would be good

The touch plate will automatically give you the z-axis work zero. Easel (or any other program) can not do that with out a touch plate. Essentially the arduino has a “probe” feature that GRBL can use. The ground goes on the bit and the power goes on the plate. When contact is made it completes the circuit and you will have the distance to the top of your plate. Then you subtract the thickness of your plate and you have the height of your work piece. Most progams will let you enter the thickness of your plate and do it for you.

Gotcha. That makes sense. I’ll give F1 a shot. I did a pretty exhaustive Google search too and came up empty as well. As good as the forum is, I’m hoping someone has an answer. I’ll definitely post the fix, should one come up. It seems like such a simple thing to wire, not much to go wrong…

oh hey just noticed something you said, are you using easel?

No. I am using vcarve pro and universal gcode sender. About to try chilipeppr, if I can figure out how to get it to work.

here is the verbose output I am getting…

g38.2 z-.5 f1
ALARM: Probe fail

F1 made no difference. I tried messing around with the other numbers too (z-.1, z-1, z-2, f1, f3, etc.) with no luck

Does the z-axis twitch at all? Is it possible you’re in metric units, and it’s moving .5mm down and then failing? Try increasing that number, since I think you’ll get a “Probe fail” message if it moves the specified distance without making contact.

ok cool. i know you can enter g code commands to easel now but i havent tried to run anything with it.

Good idea. I am in inches, but I have noticed that 1/2 the time it moves in mm intervals regardless… here goes nothing!

Just fwiw, you can use G20 to specify Imperial measurements, and G21 to specify Metric.

no luck :frowning: I went as high as z-25 and doesn’t even twitch. Just goes straight to probe fail. I’ll attach a picture of my setup… maybe I’m overlooking something

good tip with the g20 g21!

Grbl gives the probe fail error upon two conditions: If the switch is detected as active before the probing motion is performed, or if the probe command (w/ error) doesn’t hit the switch before it reaches its target destination.

My guess is that your probe switch is detected as active before the motion is performed. Either you have lots of noise in the probe line, or you need to invert the probe pin in Grbl settings.

Invert the probe pin?.. I’m listening

Also you have to get close to probe manual jogging before start commands. If it’s moving and trying to find probe more than distance you gave, it will give you error and UGS turns red lock position.