UGS and Chilipepper Problems!

So I have an X Carve and I got everything running right! I am trying to use Universal Gcode Sender to send code to my Arduino/Gshield. Every time I reset zero it seems that my measurements change, for example before I reset 1" is 1" but after I reset zero 1" seems more like 1/4". I hope the problem makes sense! Also sometimes when I reset zero in one location and then ask it to return to zero, the position is in a totally different position. Does anyone know what Im doing wrong?

I am having the same issue, it appears it is being caused by the Grbl being in mm mode while the gcode is in inches (or the other way around). You can send the G20 command to force Grbl into inches mode, or G21 for mm.

I have not been able to test this yet, but it seems like the most likely cause.

That actually worked! Whats weird is every time I reset zero it goes back to mm and I have to change it back Everytime I reset zero…I dont know if thats normal or not but it seems like once I set Grbl to inches once it should stay in inches. IDK!!
Also when I ask it to go back to zero its still going to a completely different location
Anyways thanks Allen for the input!

Glad that worked, I guess UGS is changing the units when it sets the zero position. Maybe someone one else knows exactly what UGS is doing.

OK so I also figured out that there is a work position and a machine position and the reset button on UGS resets the work position but the return to zero sends the machine to the machine position! lol So I tried to reset the machine position with G10 code and got an Invalid Command, so the only way I know how to reset the Machine position is to bring up UGS, position the machine where you want it, Close UGS and then bring it back up again, and the machine position should be at zero! Im wondering if there is a way to send the machine to work zero instead of machine zero???

Yes, that’s exactly what I’ve been doing too. I changed over to Chilipeppr today and I’m kind of liking it more than UGS now.

I will have to check out Chilipepper!! I have heard of the program before but also heard it’s a little pricey!!

Well, I guess you could say that it costs twice as much as UGS? :smiley:

It’s totally free, and seems to have good grbl support:

You’ll want to follow the instructions in the bottom right corner for setting up a little [edit: not java] app that needs to run in the background (or find a tutorial, there are probably some good guides out there).

The only issue that I’m having with it these days is when I attempt to run consecutive gcode files; after the first one completes, I’m able to load the second one and start it, and Chilipeppr seems to think it’s running it, but my machine doesn’t move.

Other than that, it’s been a pretty solid app

Hmm that might be a rather big problem for me cause a lot of the files I have use more than 1 G code file for bit changes!! Also I cant seem to open the page for chillipepper, a page will open up but its blank, just a white screen, maybe I will try again later. they may be doing maintenance to the site

Right now the workaround I’m using for running multiple files is pretty easy. I just go down to the bottom right (where you select the COM port your Arduino is on), deselect it, and then re-select it. I do this while my machine is in the x/y home position. I then issue the command to zero out my X and Y values (which is fine, b/c the machine is sitting at zero), and then Chilipeppr works fine with a new gcode file.

All in all it only takes maybe 20 extra seconds, so it’s not much of an inconvenience. I’ve been following the grbl mailing list, and it sounds like there might have been a related bug having to do with grbl not thinking a job is “finished”, so perhaps a newer build will clear this up.

Hi folks, just jumping in here on some of the questions.

  1. Serial Port JSON Server is not a Java app, rather it’s a compiled binary so that you have no dependencies, i.e. like installing Java. It was written as a lightweight standalone so you could even install it on a Raspberry Pi, Intel Edison, Beagle Bone Black, etc. so you could have a dirt cheap $35 computer next to your dusty CNC machine, but run your front-end UI from your fancy expensive laptop.

  2. For the person seeing the white screen, ChiliPeppr is hosted on Google App Engine, so it is rock solid on the uptime. The white screen may be because your browser/OS doesn’t support WebGL. ChiliPeppr’s centerpiece is its 3D viewer, but it definitely relies on the new WebGL capabilities of all modern browsers like Chrome.

  3. The problem at the end of your Gcode file may be Grbl going into an alarm state at the end of the program. Does your Gcode file send a ! or % at the end? Does it send an M30? Disconnecting/reconnecting may just be telling Grbl to reset itself.

Hey John, thanks for the input!! On the chillipepper issue, I am running windows 7 with google chrome as my primary browser and I went to chrome://flags to make sure that WebGL is enabled, it says it is, and I also tried to bring up the website on Icedragon and still a white page! Do you know if I need to do something with my OS?

P.S. I also went to to test my WebGL and it seems to be working fine ( I saw the spinning cube, lol)

Thomas, any chance you could look at your developer console and see if any errors are getting spit out. In Chrome you hit Ctrl+Shift+J to see the Javascript console. Maybe a Javascript file isn’t loading for you?

Yea Im getting these error codes:

Uncaught ReferenceError: chilipeppr is not defined(anonymous function) @ grbl:14context.execCb @ require.js:1650Module.check @ require.js:866(anonymous function) @ require.js:1113(anonymous function) @ require.js:132(anonymous function) @ require.js:1156each @ require.js:57Module.emit @ require.js:1155Module.check @ require.js:917Module.enable @ require.js:1143Module.init @ require.js:774callGetModule @ require.js:1170context.completeLoad @ require.js:1564context.onScriptLoad @ require.js:1671
require.js:166 Uncaught Error: Load timeout for modules: google

when I try to go to the java download screen I am getting this message:

We have detected you are using Google Chrome and might be unable to use the Java plugin from this browser. Starting with Version 42 (released April 2015), Chrome has disabled the standard way in which browsers support plugins.

ChiliPeppr doesn’t use Java, so this makes me think you have some kind of plugin added to your browser causing this error. That plugin possibly tries to use Java and thus this issue. Can you disable all your extensions? Or uninstall them? Or try this from Firefox? People are using the Grbl workspace as we speak and it’s working fine for them, so this seems to be your browser having issues.

I have tried chrome, Ice Dragon and Internet Explorer and all of them are the same thing!! Let me try to uninstall java from the computer and see if that works!

Nope that didnt work either…I dont think its a browser issue cause the problem is happening in all of my browsers!!

Thanks for chiming in, @JohnLauer! I just edited my post to remove the java reference, sorry about that, thanks for the correction. It looks like all my gcode files end with M30. I’m going to start a “Chilipeppr Tips and Tricks” thread, maybe we should leave this one for more UGS-related posts.

1 Like