Using vcarve

Help! I got my machine running this weekend and have cut a few tests with Easel. I purchased the V carve software and new I was going to need to use ether universal g code sender or chilipepper. I tried chilipepper but could not figure out how to use the USB port it asks for a serial port. Then I tried universal g code sender and can’t figure out how to get it to install. Any help would be greatly appreciated.

First initial Setup with Easel will install drivers for your USB connection. Actually that is your serial port, long name is Universal Serial Port. When Arduino software installed and initialized, you have to run Easel Machine setup. Universal G Code Sender needs no installation. Just open zip file to any directory, run start file which runs your UGS, you’re good to go. If you still have problem running UGS after successful Easel Machine setup, this time you may install latest Java. On that point we have strong knowledge people here can help you. Let us know if you figured out.

I recommend ChiliPeppr. Make sure that you disconnect from your CNC controller from Easel so you don’t lock the serial port. ChiliPeppr can’t connect to your serial port if Easel is stealing the connection.

I was able to get chilipepper working I was able to run a program that I created in v carve pro, but when it is through running it locks down. I can’t jog the spindle or anything the only thing I have been able to do is shut down and reboot. Any suggestions.

Yeah, I ran into that as well. I can’t remember if it was a V-Carve post-processor issue, or if I ended up updating my grbl build. I believe the issue was either the post-processor wasn’t adding an “M2” (Program End) command, or grbl wasn’t correctly processing it.

You might check your generated gcode to see what the last few commands are, and if you see an M2 in there, then my guess is that you need to update your grbl.

Try Universal GCode Sender, UGC

I have tried everything and I can’t get it to work. Universal G code sender that is

What is UGS doing when you try to use it?

I can’t get it to open up it seems it is a jar file I’ll look at it again tomorrow and let you know. Thanks

UGS works fine for me. Win7/64 - Java is up to date. Also made sure to load the latest iteration of grbl 0.9i.

1 Like

I’m windows 8 I downloaded latest java but no luck,but I will try again tomorrow.

There should be a “start-windows” or “start-windows.bat” file that you’ll want to run for UGS.

Ok I have the start windows file when I click on it a black box flashes then goes away, then I double click the universal g code sender and it does nothing I get the little working icon for just a second.

That means you don’t have the latest version of java. go to and download it

I have, no luck

it’s not luck, learning takes time when there is little documentation. We’re all struggling here or there, but it gets easier (then the machine issues sneak up :frowning: ) Hang in there

Have you figured out your issue. I have the same problem. The machine cuts the parts nicely but once it is done the machine goes to home position and just sits there. I dont get the “Job complete” alert and I cant jog machine unless I close program and open it again.

Mine did that until I upgraded to the latest version of GRBL.

Please tell me how or where you updated that…

What is your current version?