Who's having problems getting circles to come out round?

I can not get the XC to cut out a perfect circle. Anyone else have this or had this problem? Ive spent countless hours checking belts, v wheels, wires and calibrating. The issue is today i tried to pocket out a hole .635 well i get .614 to .643 in the same hole in the exact same spot. 6 holes all the same. Im not sure what is up. Ive had the XC up and running, well sort of, since June and all i seem to do is check adjust test and repeat. I have yet to do a single project other than a few simple shapes. Anyone have suggestions other than belts, v wheels,or turn up the pot because ive done that at least 30 time’s, no joke.

Do you have the stock spindle?

0.643 - 0.614 = 0.029

Almost all of the 24 volt spindles I looked at specify a run out of between 0.01 and 0.03. That would make your circles within the tolerance of the spindle.

No a Dewalt with steel enforcement in the x maker slide and bracing on the Y.

That’s at 30 in/min in mdf so im thinking a not round hole is not so good.

I’m hoping you figure this out because I’m having the same issue. Also have a Dewalt 611 (Thought it was the stock spindle at first).

I was also having the same issue and I traced it back to backlash. I use a different controller which allows me to input my backlash and allow for it while running Gcode. Once I took the time to set my SPU (steps per unit) on EACH axis with a dial indicator, it was easy to measure for the backlash then input the values into my controller. Since doing that my circles are about as perfect as they will ever be and far better than they ever were with the old TinyG I was using before on the Shapeoko and XC.

Measuring your SPU for each axis will be a big start if you have not done so already. The stock values are close, but never right on the money due to belt tension and such being slightly different on every XC and Shapeoko out there today since we all build them. Measuring it simple with a cheap dial indicator and goes a long way to fix this issue. If your controller will allow you to measure the backlash then that also will work to fix your issue. I think I ended up with about .0550mm of backlash on each axis which does not seem like much but the circles sure got better once I allowed for it on bigger jobs.

1 Like

I did calibration using a calibers on 9/1. i had the X axis set exactly for 100.00 mm and checked last night it was moving 100.52mm. The Y stayed the same. I only used the xcarve a few time since and didn’t change anything. Could it be the steeper motor on the x?

This is frustrating because just about anything a person would do on a cnc involves circles or arcs. I dont need something just for straight lines, i can do that on the table saw.

What controller did you use? And what was all involved in changing over, hardware and software?

I would adjust your SPU to allow for the new reading you got. The belts might have eased a bit after a few jobs… It seems to take a few jobs to have the mill “settle in”.

Switching over to a new controller is an easy job over all. I use a Planet CNC MK3 on the X Carve and a MK 3/4 on the Shapeoko 2. This page talks about their boards: http://www.planet-cnc.com/index.php?page=hardware and this page talks about all the features their boards have like 3D digital probing and warped milled and such: http://www.planet-cnc.com/index.php?page=features

No these boards do NOT have built in stepper drivers like the stock shield does. This is seen as a downside by some, but it allows you with use a far better stepper driver then the stock shield comes with. I use Leadshine DSP drivers which are digital and have made a huge improvement, but are not cheap sadly. I run 4X of the DM442 on the X carve with a MK3 and 4X of the DM432C on the Shapeoko with a MK3/4. I also run a MK3 and 4X DM442 on my larger all ball screw mill much like the one you see on the Planet CNC page.

To change over you would need the following: A Controller board (MK3 or MK3/4), your stepper drivers (which can range from $20 - $150 each and you will need 4), You can reuse the 24V power supply from the X carve for the drivers and steppers, A simple 12V power supply for the controller board. Their USB CNC software (Apx $69.)

The wiring bit is extremely easy but MUST use shielded wires and the shielding must be grounded on the controller end. If you go with the MK3 it is far easier to use their breakout boards for connections if you do not use their drivers.

Software wise: The controller is ar more powerful then just a simple Arduino so it is not limited by GRBL and a slow processor. But this also means it will not work with things like UGS and Chilipeppr, which is not an issues since the software does everything they both do and far more. Here is the link for the software page: http://www.planet-cnc.com/index.php?page=software and here is the manual to give you a true idea of everything it can do right out of the box: http://www.planet-cnc.com/files/CNCUSBController.pdf

The backlash setting is stock on the MK3/4 and the MK3 boards and software. It really allows you to tune the mill far above what the stock shield allows.

The one downside is that the total system as a whole is not cheap. I think with the 4X DSP drivers and the MK3 I have around $500+ into the upgrade. But I went with their best board and some of the top of the line digital steppers when I upgraded. One nice thing about this system is that if you ever upgrade to a larger/better mill you can just move this system over to it, re-calibrate your SPU and be up and running in now time flat. Since the drivers are not on the controller board, they can be replaced with they fail or upgraded if you need more power at some point.

Same issue here with Vcarve. I tried to mill their ‘Devine Clock’ Project twice on Maple, at fairly conservative speeds. Both time it failed in the last steps, which is miling the midle circle. It all seems to be off to the left side on the X axis. Not sure whats going on. I also have the 1000mm Xcarve with the Dewalt. using a .125 bit and 0.1 inch per pass. I tried the inner circle once with a Raster carving, and once with the default offset carving that basically goes in circles from the inside to the outside.

Picture of the second failed attempt (with the Raster carving):smile:

So far, the Xcarve has been fairly problematic. I have used a NOMAD 883 for half a year and while there were problems too, there were no problems like with this machine.

Also, Pots on X and Y are already up, nuts are tight machine is straight and belts are tight as well (by the way, is there a guide on HOW tight the belts should be?)

OliverBlum, EdSirignano when did you get yours? What computer operating system, what prosseser and speed, and what CAM program?

Talk with Inventables tech again today. Here is a few things i was told to try and all failed to correct the problems as ALL the suggestion yesterday.

  1. check the wires to the Y axis motors to see if they have the same number of copper strands. ok did that today, cut them all and reattached.
  2. PUT BACK the original SPU to 40.00 " they are set at 40.00 for a reason, that could be a issue".
  3. I asked if it could be one of the steper motor," no".
  4. I asked if it could be the Arduino, “no”.
  5. I asked if it could be the GRBL, “no”.
  6. I asked could it be the post processor, “no”.

So did this and no change. I decided to Swaped steppers from the x axis,z,axis to the y axis and the y’s to the x and z. Supperise NO change.

This is where im at. I have spent way to hours checking, adjusting and testing not to mention wast material on this machine. As of now i have 6 table saw inserts, 2 push sticks and 4 set up squars that cost me right at $1500.00.

If customer service is out of answers then the Xcarve is not even a very good TOY cnc.

@GiavonniPalombo Hi,

I am sending the files from a Windows 7 PC, UGCS. Used VCarve to produce the files. Speed is at 80 ipm and 0.1 depth per pass. Using the Dewalt 611. Carving into 0.75 inch maple.

I tightened my Y belt on one side, and made sure that the distance between the first wheel and the end of the Y rails matches ob both side. I restarted the job again to see if its any better now, we will know more in about 1h.

I agree, so far it has been a fairly frustrating experience. Like i said the Nomad 883 had it’s issues too, but their support is superb (even personal sessions on skype!) but not issues like this. It would be nice maybe if X-Carve would sell a large (same size as the large Xcarve) pre-configured and calibrated machine instead of only parts, that would probably help. Or at least they should make it easier to measure parameters like belt tension or other things.

Ok so my job just ‘finished’. It went wrong again, exact same way as the previous job. I start to wonder if for some reason the VCarve file causes that issue, because i would think that if a belt slips or if something else goes wrong, it would not be wrong the exact same way.

If somebody wants to try the file, let me know and i can send the file. It just needs 0.75inch thick wood, 11x19 and a 0.125 cutter.

1 Like

The problem im having is the same in vcare and easel. Im thinking its something else, post processing possibility? Why else in 2 programs would it do the same thing?

Is there a big rapid move just prior to the problem. If there is edit the Gcode and make that move a G1 move at the same feed rate you are cutting at.
There is a good chance that a big rapid move is causing a loss of steps that cause the problem.


I dont think there is. The endmill is starting at 12:00 and the worst part is at 5:00. Measurements around the circle vary. I running at 30 inches/min and a plunge of 10 in mdf. Is that still to fast,for a circle that size, less than .5 inches?

Please see this thread, fella. I was ready to pull my hair out after many days of ts’ing.

JDM, ill try that. Finally someone giving a way to tension belts in a way a person can actually measures! Now only if a way to do the v wheels. Or if inventables could come up with a better v wheel tension system . Sometimes along the lines of the way a dirt bike chain is tensioned and one axle for both v wheels.

like Robert said, very tight to turn with finger pressure.

and use loctite

Are your bearings in the v wheels easy to pop them out or can you push on one side and it makes a popping sound? I have taken every v wheel off and every bearing is loose inside of the v wheel. Three of them fell out on there own. This may be the issues we are having. If not then i don’t know what else it can be. I have checked everything and tried all suggestions.

I have tried all kinds of things (see this thread for pictures and videos etc: link
I will check for the popping sound though again later once i get home.