X Carve not responding in Easel or UGS

Everything with my X Carve had been working great until yesterday. I went to start a project in Easel and had no response from the X carve. After checking connections and attempting jogging the machine in Easel and UGS, I am left scratching my head. I do notice that I dont hear the steppers “engage” the way they used to when I powered on. There is only a slight click sound now. With the power off, moving the steppers causes the corresponding light on the gshield to illuminate…so wiring doesnt seem to be the problem. Any ideas out there of what I can try?? Please help!

Jason

Check the g-shield to arduino connection. I had an issue with the g-shield not seating all the way onto the arduino because the openings on the side of the enclosure wouldn’t allow it to go down far enough. I still got the lights, and moving the motors caused the lights to flicker, but I wasn’t getting the signal to go through. Removed both from the enclosure, seated the shield properly and tested it outside of the enclosure and it works great. I need to trim the opening for the header connection on the front side of the enclosure so that it can all be screwed back into place and seat properly. I’m running it loose in the enclosure at the moment.

I did re-seat the gshield on the arduino when checking all of my connections. But I’ll try removing both from the enclosure attempt running it and see what happens. Frustrating because it was just working perfectly the day before yesterday. Thank you for offering your help!

I just had this happen. I just shut down easel, turned off the X-carve, unplugged it for a few seconds, then turned everything back on and it worked fine.

Can you see the Arduino/port in Device Manager?

Yes, the arduino is in device manager. Also grbl 0.9i is recognised in UGS when I start it up. Puzzled!

Pulled gshield and arduino out of enclosure and tried again. Same result. All connections seem good, Is there anything else I can test??

Are you using a Laptop??

If your using a Laptop, it may be your ports! The same exact thing happened to me, the whole discussion is here:
Port Problems!

Basically your laptop port dont have enough power to power the Arduino, it will work for a while then one day nothing! My fix was a desktop, but you can buy a port hub with an external power source! I spent about 2 1/2 weeks troubleshooting this problem! Here is a link to the type of Port Hub I am talking about,

Disconnected everything. Reflashed the arduino. Then put everything back together…it works! Not sure if it was a connection problem or if something happened with the arduino. But now Im back in business! Thank you guys for your ideas and assistance.

Jason