X carve pro losing place

I see that there are a lot of forums related to the x-carve
losing place. However, I don’t see any other machines doing what mine is from pictures. For whatever reason, at some point various through a carve the machine seems to completely lose place and skirt in a random position on the y-axis.

I’ve checked all of the cables and don’t see what’s going on.

I currently have an ex-carve pro which makes this even more maddening considering the cost of the machine.



Can you go to machine inspector (Press Crtl+Shft+D) and retrieve some data:

  1. What is the Firmware Version of the CNC? This should be “grbl 1.1.h” or similar there have been updates to this since the XCP was first released, so updating this may help with the issue. The current version number is located in the top left corner

  2. What are the machines grbl settings? These are located at the very bottom of the machine inspector page. Just to verify that these are all set correctly.

Hey Gregg i see that the $1 & 120 is set wrong.
$1 should be set to 255
And $120 should be set to 250

$1 being set to 0 will cause the steppers to not be locked in place when they should be and can cause the z to lose height between probing z zero and starting the carve causing carves to be too deep.

And $120 being set to 500 can cause the x axis strepper to lose steps and lock up from driving to quickly.

So although these might not definitively solve the issue, they would have a positive effect by changing these settings

If @SethCNC’s solution here does not work, it does look very similar to the issue I was having not long ago.

I have not seen the problem since I stopped using Easel to send my GCode. I use Universal GCode Sender just fine with my XCP at 57600 Bd. I like the features better than those offered by Easel for machine control.

If you do not create your Gcode with another third-party - such as CarveCo or Fusion360 - you can use Easel.

How to Export Gcode from Easel

It could also have something to do with the USB settings of your connected computer, which is what an Inventables technical support representative clued me into. If it is a windows machine, you might be able to check your “Power Options” settings for USB. I was using an Ubuntu distribution, which does not manage USB power the same as Windows.

image

Hope some of this helps.

Edit: Added link to UGS.