X-carve setting for theZ Axis

I just upgraded to TBD Super grad for the Spindle to give me more cutting height, now what do i have to do to the program to make it work correctly

You need to change the $102 which is the steps per mm for the Z axis. It’s a matter of doing some math. You set it to move an amount, say 1 inch. and then determine the actual measurement. It’s a ratio and multiplied by what the setting is now gives a resultant new number to change to.