Inventables Community Forum

Steps/mm Calibration

I found this video through the X-Carve sub-Reddit (r/X-Carve) and thought it might be helpful!

7 Likes

Someone posted this in a thread I started a day or two ago. It’s a pretty informative video, and I’m going to check mine in the next few days.

Oops, sorry for the double post! I did do a quick search if anyone posted this yet, must have missed it!

I think I’m going to check my z-axis atleast, it seems all my cuts come up short of cutting through my material, this is probably the reason.

It was here…Just a link, no video embedded in the post. No worries, though. We can never have too much information!

saw this video the other day. checked my grbl and its at the 40 mm like his was in the video but havent had a chance to actually test. i suspect my Z axis is off a little bit so this should help

1 Like

how do i know what my x-carve settings should be?
NEMA 23 Stepper motors; ACME lead screw kit; GRBL 0.9i and the Arduino is what ever shipped from Inventables.

real interested if my machine is set up correct

I think those numbers are posted on here somewhere, but if you run the tests in the video you should be able to tell. If you run the Easel setup for your machine, you should get to the default number meant for your machine.

I have to wonder if he is really over-rating his steps/mm because of backlash. I believe it is a fine balancing act to dial in steps/mm while compensating for the backlash that happens when you go back in the opposite direction. It would be wise to move in both directions to see if you have enough backlash compensation first before you start trying to finalize the steps/mm too finely. I am not at this point yet due to scheduling conflicts (work gets in the way of fun too often), so I would love to hear from someone who has already addressed this, and maybe see another video on the subject. Hey @Zach_Kaplan, wouldn’t an adjustment/setup/fine tuning video be a great Tip Jar Bounty?

1 Like

@makermark i’m gonna share this internally and discuss.

I bubbled up my results on my SO2 in another thread but will touch on them briefly here.

When running a calibration pattern, the square and circle were not exactly as they should have been. I didn’t keep my notes, so I’m going from memory here. My long axis is X, gantry is Y. I was able to test my X axis over a range of 40" and came up a tiny bit short. After some experimentation, a setting of $100=40.04 corrected the error. Before I checked the Y axis, I set $101=40.04 and got an exact measurement. For my Z axis, I had updated to a NEMA23 belt drive with ACME thread lead screw. The initial setting of 188.947 was to be reduced in half because of the 2/1 pulley arrangement, yielding 94.4735. I was getting more travel than commanded on Z so I adjusted the setting to $102=94.5 to get the correct travel.

2 Likes

@Zach_Kaplan - Here’s another thread to discuss:

@Zach_Kaplan,

I’m working on a calibration video for my X-Carve (Creating Calibration Guide). If your smart fellers have any specific numbers that shouldn’t change, please let me know and I’ll make sure to say “don’t change this, ever” in the video. I wouldn’t mind a Tip Jar Bounty though… :smile:

Rob

1 Like

Back when I was running the Shapeoko 2 and the TinyG I noticed I was not getting ROUND circles and everything else was squared and all that fun stuff on the mill checked out fine… I ended up using a .001" dial indicator mounted to the slotted bed to measure the SPU on the mill. I found the stock values were off on every axis. Once I got these dialed in for each axis, the circle came out far better. But as the TinyG did not allow for any sort of backlash to be allowed for, they were never 100% perfect. But calibrating each axis was a big improvement over leaving them stock. By the math, the values should be 40… But the real world measurements did not bear that out on the Shapeoko 2 or on the X Carve once I got it either. Now that I have switched to a Planet CNC MK3 controller, I am able to measure and allow for backlash as well as calibrating each axis since this is a feature on the controller. While the values are only SLIGHTLY different from the stock value of 40, and the backlash is only around .0550mm on the X and Y axis for the X-Carve… Getting those values calibrated over the stock setting has allowed me to greatly increase the repeatably of the mill from one project to the next. Just in doing my write up on milling of PCBs I took a break on night and decided to measure and factor in the backlash on the mill, then I reran the PCB mill job. The difference in the boards was easy to see with and without the backlash settings.

I can not offer a true explanation as to why there is a subtle difference in the real world measurements VS the “stock” numbers they should be at. But I know the real world difference the mill performs at since I have calibrated each axis with the dial indicator

I look forward to seeing where the debate on this lands and also very much what the guys at Inventables have to say and think about stock Vs measured SPU values.

2 Likes

I have to believe that the belts that come with the machine are only 2mm pitch when there is no stretch to them. Having only fiberglass tension members I have to believe that when they are under tension that the pitch increases just enough to cause the difference from the stock value of 40.

Dave

1 Like

That was my working theory also. Since there is not a true set way to make sure all the belts have the same tension from one mill to another would seem to account for the minor differences we all see from one mill to another.

Does anyone know if there is a belt type out there that does not have the stretch to it that would alleviate the belt issue?

If you can find Kevlar or steel reinforced GT2 2mm pitch 6mm wide belting let the rest of us know.

1 Like

I changed my belts to 9mm a few months ago and haven’t had a slip yet. I had to make my own belt clips but all other parts were available online.

1 Like

BillArnold - Interesting concept to use the 9mm. I may look into that. Not a bad price on amazon for the change over (~$26). What did you use for the belt clips? I assume you had to change the grbl settings also?

@AngusMcleod - Wider to fit the 9mm belt

@JeremyHill - I had some Lumicite (acrylic with fiberglass) in stock. I modeled my update after the original SO2 clip. No change in grbl since the configuration is the same as the 6mm belt.