X-Carve will not connect to Easel

We have just installed the new laser but after we installed the laser now the X-Carve will not connect to Easel. We have tried with multiple computers. We have uninstalled and reinstalled drivers. The laser is working, we just now cannot get the x-carve to work. We have been over this thing with a fine tooth comb and all the connections are working. I have a green light on the x-controller box. The computer is registering that I am connected to the x-controller but the website wont. I do not understand…could use some help. Thanks

Try re-booting the computer. Sometimes Easel leaves the serial port in an undetermined state. If this is your problem then re-booting will fix it,

Using the xcontroller or the arduino/gshield?

Nm see it now. Seems stupid but several people have had this issue. It turns out the estop isn’t pulled all the way up.

Com port is good. Removed all antivirus still will not shake hands with Easel. Have tried several computers… It did work fine and then just quit.

Try downloading easel again.

Still will not connect. We’ve downloaded easel a dozen times. Went got another computer and started fresh. Nothing!

Did you try ftdi driver again? So, it shows up in device manager.

Is the laser completely off/unplugged?

It does show up as com 3. When we try to manually connect through Com 3 it does not like it just sits. Got a feeling this may be the trouble.

Laser is unplugged.

Ftdi driver?


Tried it all. When we try to connect the com port manually it just sits not like it cannot connect to it.

Goto device manager and uninstall. Start over. It’s a driver conflict, not easel. It usually shows up as com 5

Just deleted everything. Reinstalled and it still assigns it to com 3. Tried manually connecting to the com port again and it just sits. How can we change the com port to 5?

I run mine on com 3.

Have you been running the xcontroller for awhile or is everything brand new?

Brand new. We cut some things last week with no problems. Bought the laser and hooked it up. Got ready to burn and easel will not connect. We disconnected the laser but nothing helped. Does seem to have a conflict with the com port. Its the same on two different computers.

Just hooked up to another computer. Same issue!

Check the connector inside, mine came loose, I guess I didn’t plug it all the way in.