X-Carve Wireless Proxy Tutorial Using a Raspberry Pi

Hi,

I just finished a tutorial for Adafruit on how to setup a Raspberry Pi to wirelessly relay commands from Easel running on my computer to the X-Carve. I added automatic power control so the X-Carve power supply is turned on when Easel opens on my laptop, and turned off when Easel is closed.

Relevant links:

Not sure if people are interested in this, but it seems to work nicely for me. Please let me know if it works out for you if you decide to give it a shot.

9 Likes

Very nice! I’ve been meaning to look into using a RasPi to run a remote Chilipeppr session, this is a great tutorial, thanks!

Something I’ve thought about since before ordering my X-Carve. Great tutorial and resource! Thanks.

Fantastic! Thanks @ToddTreece

@AngusMcleod what OS are you using the Pi Finder on?

@AngusMcleod ah. i’ve only tested it on Debian, OS X, and Windows. i’m guessing there is something weird with the version of arp that comes with slackware.

try SSHing into the pi, and running this:

curl -SLs https://apt.adafruit.com/install | sudo bash

you can then set stuff like hostname and wifi creds using the occi helper util:

@AngusMcleod that package is intended for new linux users, and installs some helpful utils, including stuff like mDNS and the latest stable Node.js which are required for the xcarve-server Pi project. the command below should get rid of everything if you don’t want to setup the Raspberry Pi X-Carve proxy:

sudo apt-get autoremove occidentalis

I ordered my kit to go wireless from Adafruit earlier this week. @ToddTreece - glad to see you are on here. This is my first time with Pi - I’m sure I will have a question or three!

I got all the parts mentioned in Todd’s tutorial on Adafruit.

@MikePlummer happy to help if you have questions, and let me know if there are any steps that need clarification.

1 Like

@ToddTreece - I’ve got my pi kit but the Pi Finder page in your tutorial doesn’t have a Mac link.

I did see the note at the bottom of the overview page pointing to this page, and it connects to my pi, but when I paste ssh pi@ip into terminal, it asks for the pi’s password. I found the default password in my pi’s instructions, along with the instruction to open a graphical interface by entering startx, but all that does is return some build info and at the end says FATAL: Module g2d_23 not found.

Do you have a link for a Mac-friendly version of your Pin finder?

Edit…I found this page and was able to get into the occidentalis.txt and enter in my pi’s name & network name/password, but how do I save that info & move on? I assume it was WriteOut or just Exit, but neither of those commands do anything for me and it just sits showing my network info.

At what point do I use $ curl -SLs https://apt.adafruit.com/bootstrap | bash?

I also tried the sudo raspi-config configuration tool but didn’t see anything in there that looked like what I needed.

@MikePlummer Here is the link to the OS X download: Adafruit Pi Finder for OS X

The instructions on how to connect are actually on the third page of the Pi Finder tutorial: Finding and Connecting to your Pi

You shouldn’t need to start the X windows environment (startx) for my tutorial. Everything is done through the terminal. Let me know if that doesn’t clear things up.

Connection & server install went without any problems, and I’ll make the equipment connection this weekend. Thanks @ToddTreece!

Hi @ToddTreece hope you can guide me here. I am just in the process of completing this set up, following the instructions from learn.adafruit.com, however I do not get to connect to Easel as expected.

Now, when installing node.js I seem to run into an issue. even though I chose v.0.12.7 from this link https://nodejs.org/download/release/v0.12.7/docs/download/ (windows) and controlpanel displays the correct version, I do get the version v0.12.6 when checking with the comand node -v in the terminal.

I went ahead and continue with the pocess however i noticed the following warning when running this command: npm install -g forever xcarve-proxy.

I think this might be related to the nodejs issue above and probably is preventing the proper connection to Easel however I have no clue if that is in fact the case.

Easel app was uninstalled from the computer as per the instruction.

Would you mind to share some advise on how to overcome this hurtle… Disclaimer: My programing skills are extremely limited.

Thanks

Hi @ToddTreece,
I am having trouble with the install on my Pi2 running Jessie. nodejs is 4.2.1 not 0.12.6 but I am getting a lot of errors at the end of the install.

How do I install this? Do I need to go back to an earlier nodejs?

Thanks

Fixed it! Archived back to v0.12.6 and ran like a charm!

Well, I went through all the installations and didn’t encounter any problems… Except both Safari and Chrome are showing the “You need to download the driver” page on Easel. Is there a way of verifying whether I have everything configured correctly?

@NeilG, @GeekDad63, & @Aladdin:

I need to rebuild my X-Carve’s Pi, so I’ll try running through the tutorial with the latest Raspbian Jessie, and will update things as needed. I’ll report back soon.

Is there any progress on this? I would like to get this working and have both sides installed to the versions specified. I suspect that easel has changed so this proxy won’t work… So any updates would help.
Thanks,
Brent S.

@Aladdin I got just as far as you did and then gave up. Did you get it figured out past this point?