X-carve won't connect

i finished my x-carve yesterday. I woke up and tried to connect the machine to my computer. It just stayed at the loading screen for ever. I went on doing this for about 90 minutes then i decided to try a different browser. Still nothing. Then i tried it with two different computers. Should i re-flash the arduino?

Im using a mac
newest software version
safari, and chrome
stock cable.

when i plug in the usb and power cable the 3 green less light up as well as a blue one.

i hope thats enough info for someone to help me. It would mean a lot if someone could help, I’ve been trying to connect for 5 hours.

Same issue here with my new Xcarve. There is also another topic or two with others with the same problem. I am awaiting a brilliant revelation and solution from someone to get me up and running. Hopefully, someone will have an answer for us soon. Good luck.

This thread is a re-post of another thread found here: X-carve not connecting

This specific issue could be related to El Capita , which is still in beta.