X-Controller troubleshooting

Completed my unboxing and setup of the X-Carve (1000mm). The instruction were remarkable and easy to follow.

I have ran into a snag and I believe that it has to do with my controller. I have tried 3 different operating systems (Mac, Linux & Win10) with no luck connecting to the Controller. I have install the appropriate drivers for each, walked through the setup on Easel (easel.inventables.com/setup) and when I click “Confirm setting” it hangs. I can hear the motors clicking or locking but I do not progress past this point. I know there is at least a partial connection to my computer as a COM port is established.

With some back and forth emails with the inventables support team it was advised that I re-upload grbl following the instructions located here (https://inventables.desk.com/customer/portal/articles/2058884-how-do-i-re-flash-grbl-to-my-x-controller-arduino-) . In doing so, it fails to upload. Error “avrdude: stk500_recv(): programmer is not responding” Went into my device manager and manually set my port speed settings to 115200 as recommended in other posts within the forum. Same result.

Went as far as re-assembling the x-controller. Also, tested the leads going to the E-Switch with an ohms meter and the E-Switch itself in the engaged and disengaged positions. All good.

Hopefully I’m missing something simple. Please advise as to what I can do to troubleshoot this issue.

Any information would be greatly appreciated!

@TimStrawn

I don’t recommend 1.1f/g for laser work, but it’s fine if you are just using the spindle.

Here are the official firmware .hex files for the X-controller.

You can load it into the Xcontroller using Xloader. Scroll down the page to find Xloader instructions.

Not sure that I am running grbl on it yet. The version that was recommended to upload I believe is v1.1g @ https://github.com/inventables/grbl

You can only have one program at the time using the serial port your X-carve is on.

Thanks. I think my issue is with connecting to the X-Connect I’m not able to interact with it either though easel or Arduino IDE even though it esstablished a com port when using the IDE and the Easel Service is running when using easel.

On windows have you tried reloading the FTDI driver?

Some X-cotrollers have bad bulkhead connector problems have you tried hooking the usb cable directly to the Xcontroller board (requires a different usb cable)?

I have tried reloading the driver. One thing I have not tried is bypassing the bulkhead. Let me give it a try.

What happens when you try to connect to the X-controller with the Arduino IDE serial monitor?

Does it just sit there? Give you any output at all?

Do you have the correct board type and COM port selected in the “Tools” tab of the Arduino IDE?

At the bottom of the serial monitor do you have 115200 baud, and newline selected as “end of line”?

Error Message Copy.txt (2.4 KB)

Correct board type and COM port selected (Arduino/Genuino Uno - COM 3)

No output on the monitor. I have attached error message that I recieved after it attempts to upload.

Have also tried to bypass the bulkhead. No change.

Make sure that the selection for “end of line” is set to “NEWLINE” for the serial monitor.

Try to use Xloader to flash this firmware to your system using the firmware version in this .Zip file.

Use the version of “Xloader” linked to below the .hex files.

You can’t have any other program using the serial port that you are trying to upload to.

Tried the Xloader with the 115200 baud rate. No luck, the program froze up on me while uploading.

To ensure that nothing else was utilizing the COM port I shut down the Easel service and the only thing running was Xloader.

Call Inventables. It appears you have a faulty main board.

Also try:
Unplugging USB cable, restarting computer, replugging USB, open arduino only.

That was my suspicion… I’ll re-engage with inventables this week.

Thanks for your help!

I am now up and running! It was a faulty controller board. The replacement worked like a charm!

1 Like