X-Controller with Openbuilds NEMA 23s - moves each one step and stops

I connected an X-Controller to a CNC using NEMA 23 motors from Openbuilds (mt-2303hs280aw-ob) and when I go to set up the machine, each axis will move 1 step and stop.

Any idea what this could be about? I unplugged the limit switches to make sure I wasn’t getting a false positive and it still happened.

This whole machine worked with its earlier (terrible) controller, and I wired the motor wire colors correctly.

Some pictures of your motor wiring would help.

Also post the $$ output from grbl here.

Thanks - here are photos, pretty straightforward assuming these stepper motor wire colors are universal (white, green, etc.)

As for GRBL $$ output - I’m not sure how to do that tho I can figure stuff out - what do you use to see that output?

Lets start at the lowest point since it’s a bit of an unknown.

read through this

Don’t assume that. Depends on manufacturer and sometimes date of manufacture. Pretty easy to test the pairing, though.
What are you using to control the machine (what software? Easel, UGS, CNCjs, bCNC, etc)
Basically you need to type $$ in the console of your chosen software. In Easel, it’s in the machine inspector.

With an unknown stepper the fastest way to identify the two wire pairs is to measure resistance with a multimeter.
A pair will show some resistance, the others will show no continuity.

I’m using Easel.
In Machine Inspector I see an alert “Detected errors communicating with the machine”

In Machine inspector the homing switches do show that they work, and when I type in $$ to the machine inspector I get the following.

Does this make sense to anyone? Thanks for your help!


Oh also, when I test the X wiring as an example, the Black and White wires show resistance between them, and the Red and Green do as well - does that tell me if this is wired the way the stepper motors in the instructions are wired?

Wiring should go black, white, red, green. One of your Y motors should have ONE pair flipped (switch red and green). If anything moves the wrong direction flip one pair.
In the machine inspector, turn off the verbose output. When you send $$, the controller should return a series of $ settings. What you posted is just idle status reports.

As far as the connection goes, first thing I’d try is closing Easel and all programs, unplugging USB, opening Easel, plug in USB. If that doesn’t work, restart your computer. Still having issues? Post again.

Thanks so much - that worked. (Actually the wiring that worked in the right orientation is black, white, green red and then flipped for the Y2 motor).

Now on to calibration etc. Very happy this is working!

1 Like