Inventables Community Forum

Xcarve pro won’t home

When I home machine, it seems to be be going to location fine, but the seems to keep clicking at the Y1 at the end, like it it wants to keep going. Then just won’t stop until I click stop

Can you go into machine >general settings> machine inspector and verify that the switches work when pressed by hand? M

Mine is doing the same thing - went to the machine inspector and pushed the x/y (both) and the z buttons all the lights turned green.

I rand the homing sequence again with the x way down the line and I pushed the x button and the machine thought it had homed. However, when running it again it appears that there isn’t anything there to push the button on its own. Any other suggestions?

This just started happening to me 5 minutes ago too

Did you ever get this fixed?
I did everything the technical support told me to do and mine still isn’t working.
I think mine is an issue with the spindle chassis not making contact with the X limit switch.
The switch is definitely working, when I push it manually the green light comes on in the machine inspector. but when I run it through the homing sequence the green light isn’t triggered.
Super frustrating, I feel like I’m spending more time everyday trying to fix this thing than actually making stuff.

Problem solved!
I moved it all the way over to the right until it locked up.
I gave it a couple of love taps with a rubber mallet to unlock it.
Ran the homing sequence and it worked!
I think something got misaligned before, apparently all you have to do is hit it with a hammer!

Hey, thanks! I haven’t fully dove into trying to fix the homing just yet because I was still able to get things cut and and just jog the machine.
When u say u moved the machine to the right so it locked up, are you talking about the spindle to the Y2 side the farthest it can go? And when u hit it with a mallet , u hit the spindle to the left ( right side of spindle Toward y1? I mAy mess with it later tonight.

Yes it happened by accident!
I moved the spindle all the way over to the y2 side. And then jogged it one more time. There’s a safety that locks the screw from moving any further, you’ll notice it won’t move back and it makes a weird noise.
I hit the right side of the chassis. Not on the spindle but the area above it. Then I jogged it to the left (toward y1) just to make sure it’s unlocked.
After that I homed the machine and it was good as new!