XCarve stops randomly

I was having a similar problem but for a very different cause.

I recently switched to a tinyG controller and chillypeppr and have been having good results. I was trying to do a very simple carve of a cut file I had used before no problem, but the carve kept crashing. The XC shutting down completely, even shutting off the spindle (that should have been a big hint to me)

After 8 crashes resets or sometimes full re-boots I sort of finished the carve. The alignment errors from restarting made things not and nice as I would have liked but I worked with it. I was more worried that I may have a bad controller that the messed up cut.

Later, after thinking about it, I realized it was most likely a limit switch alarm and shutdown.
I was used to UGS actual listing an alarm error message when this happened. Apparently Chillypeppr or tinyG does not? Or at least not in a way I recognize.

Testing it, I air cut the file and tripped a switch. Sure enough, shutdown and lock up, same as before. I was not aware of anything having changed but I guess I was getting some noise on the switch wires? So I when into settings and disabled the limit switch function, setting it for homing only. I will have to do some more cuts and see if that fixed my issue.

@AaronMatthews

Set homing and soft limits. Once you do the homing sequence the switches are ignored. Soft limits will catch an out of bounds condition and raise an alarm.

1 Like

Well ladies and Gents, I would like to pronounce my XCARVE fixed. I have been able to run multiple programs through the machine. Some lasting as long as 6 hrs and the machine worked perfecty. I highly recommend you connect your machine to a UPS. I have the computer and the power supply to the xcarve connected to the UPS. I have the router connected directly to the wall outlet.

Picengravertoo gave the best advice.

If you stop and think about it, the xcarve cost as much as our big screen TV’s, they should be protected from brown outs and lighting strikes.

3 Likes

Never mind the problem is back.

What is your cooling situation? If memory serves, the stepper drivers used on the x-carve have thermal shutdown protection. If you are pushing them at or near full current without sufficient cooling, they will overheat and shut down.

1 Like

I have a mouse keyboard and Wi-Fi dongle.

I have a swamp cooler inside of the garage. Feels pretty nice. I have done the calibration on the motors. With an IR thermometer the motors hover around 90 degrees Fahrenheit. I don’t know what else to do I guess I can double check to make sure I’m not pushing too much power to the motor is even though they don’t seem hot.

Yes the Wi-Fi is a small USB dongle looks like the really small memory card. And it is a desktop. I think what I’m going to do is use the Wi-Fi to transfer over digicode and once it’s transferred over to the desktop I will disconnect the Wi-Fi dongle and see if that helps. At this point I’m so frustrated I’m not willing to experiment and buy a internal Wi-Fi card. I think disconnecting it after I turn to the code will Aid in troubleshooting

1 Like

I can’t get it to reconnect to the x-carve unless I reset the computer now

1 Like

Do you have a fan blowing over the gshield?

Nice, OK try that

I do

Yes fan is in the g shield

Do you still have to disable the Arduino port at times? Have you figured out what is the cause that is making it do that?

I’ll get to do in this adjustment. I’ll report back

1 Like

This could if been it. I adjusted the each of the POTZ down to 1.5ish. I was at or slightly above 1.6.

On a similar note I would measure the temperature of the grbl board as soon as I remove the fan. The temperature was between 105 and 110 degrees Fahrenheit. This is with the volts set at 1.5. would you guys mind checking what you have. I just used a IR thermometer.

1 Like

@TonyRamirez

You can check here to get more information on the Vref setting:

1 Like

I had this problem - solved it by running the USB for the Arduino through an externally powered USB hub.

I was running through a desktop, so I thought there’d be enough power in the USB jack to make it work. Apparently not. I noticed that if I plugged something else into the same USB jack that the Arduino connected to after it stopped, the jack was “dead”. Restarted the computer and it was alive again. So…my theory was that there was some sort of “protection” circuit on the USB jack that if it pulled too much current or something else went wrong it would hard stop and not restart until the computer was restarted.

Whatever the problem was, using an externally powered USB hub ($20 a best buy) has solved my problem. Maybe it was the cable that came with it and the hub doesn’t matter? Who knows?

For what it’s worth, I am sending GCode through UGCS…never had this problem with Easel, but I never ran half hour carves on Easel like I do with UGCS.

I’ve had my XC for a few weeks, made a few small carvings, just tinkering trying to get it all dialed in. Tonight, it just stopped, spindle, vacuum and all movement.

I replaced the USB cable first thing. Fixed the problem!

I had this issue and figured out it happened when I ran my shop vac on the same circuit as my system . Changed to a different out let that was on a different circuit and problem solved