Inventables Community Forum

Xloader - instructions

So I just went back in this thread and found where I posted my settings and compared them to the file you provided.
Then you had me change $3=3 to $3=4
So I think the current setting is $3=4
So if I DO NOT want to invert Z, and I DO want to invert X & Y, do I then set $3=3 ?

Phil,
Wow,I’m going to have to let that one sink in for a minute.
But I will definitely give it a try this afternoon.
thank you.

when I look at that, in my mind I will be inverting all three axis.

I think so too. So if Z is moving in the correct direction and X and Y are not then you need to set $3=7 to get them all moving in the correct direction.

2 Likes

I’m certainly not arguing with you guys.
And I will definitely make the change.
I’m just having a hard time wrapping my pea brain around it.

All that being said.
What is causing the change from my original setting?
If $3=4 worked before, (my original setting) then why did it change to $3=7?

The theory is that $3=4 didn’t really work before.

You are correct if $3=4 really worked before then it shouldn’t change without a wiring change.

I’m dumping what came before in preference to making it work now.

2 Likes

Well I’m back in the shop.
So I checked and $3 was set to $3=7
so I changed it to $3=4, and everything moved in the correct direction.
I also saw that $22 (to turn on or off the homing cycle) was set to $22=0, so I changed it to $22=1
I also changed $23=0 to $23=3 (also part of the homing cycle)
Then I changed $24=0 to $24=25.0 (the homing feed rate)
Then I changed $25=0 to $25=750
I clicked save. then I clicked return
then I tried out the moves.
everything seemed to work fine.
so I closed picsender and reopened it up
all of the settings were back to where they were.
Please tell me what I’m doing wrong.

1 Like

Jan, PicSender stores the parameters in the Laser.txt and Spindle.txt to be able to switch back and forth when you select either spindle or laser.

In order to make the changes persistent after you make the appropriate changes and “send” them to grbl you also need to “save” them to the file.

You need to make the changes for the “laser” set of parameters and also the “spindle” set.

1 Like

Jan,
You did not save the settings to the Spindle file, I think.

1 Like

no I did not do that.
where do I need to store the file when I save it?

Click the ‘Save’ button - correct location will display.

1 Like

PicSender knows where to put it, just press save and then when it asks for the filename use the appropriate file for the set of parameters you are changing, either laser or spindle. When it asks if you want to overwrite the file say yes.

1 Like

Click Help > Tutorial.

1 Like

Right now everything appears to be moving correctly except the $X command.
When I open up the program, and just want to unlock it (without using the homing cycle) to move to a position and call that XYZ zero, it just barley creeps along.
in fact, once I move it in one direction (as in -Y 2inches) I cannot make another move after that .

I do however feel that I’m making progress today.
And I thank you gents for all your efforts.

All the $X command does is to clear the alarm. If it clears the alarm then it has worked as that’s all that it does.

Look at the box below the gold “Mode” button in PicSender. It contains the feed rate. You can modify the feed rate to make the machine move faster when you jog.

its set for 200 inches per minute.
but it moves ~2 inches per minute or less

200mm per minute is under 8 inches per minute…do you have it set to metric?

Jan,
It is a bug. When you $X, Grbl resets to its default state of G21 (metric) and G90 (absolute).
This will be (is) fixed for the next update (soon).

As a workaround for now, after $X, click on the Metric check box to select it, click OK on the popup, then uncheck the Metric check box, click OK again. Then, click on the yellow Mode button to reset to G91.

Sorry it’s a little clumsy. :flushed:
John

2 Likes

Robert,
You just said yourself that you don’t use homing.
While homing can be very useful, I want to be able to set a piece of wood on the machine, use the $X to unlock it, then jog to my work XYZ zero, call that XYZ zero and run the program.
When I was using UGS I di it this way almost always…
I just save a little time is all.

John,
Cant wait to try out the update.(please put me on your list)
All of you people are fantastic.
Thank you all for your help.

2 Likes

I don’t home my machine every time either, sometimes I just jog to the material, set my zero and go. It all depends on what I am cutting…