Z axis cuts 2x depth at 95% of job completion

This is extremely frustrating… I’ve had this screw up 2 jobs now. I thought the spindle was hitting a mount, so I moved them as low/out of the way as I could, but it’s still doing this at the last 5% of each job!

I watched it as it did it this time, there were no motor grinding noises, no skipped steps, no belt slipping on z, it just started cutting at 2x the depth all of a sudden, into the wasteboard!

I’ll upload the gcode, and a pic of the jobs. You can see they both went haywire and cut through the material around the same time. These are jobs that take ~4 hrs, and were written out of fusion360 with the generic grbl post processor.

Someone help!

here’s the gcode:

chunk11_2x.nc (1.5 MB)

Are you zeroing to the bottom of the stock or top? You say the job is at 95% but is it possible it’s done and it’s trying to return to home after completing?

1 Like

looking at a visualization of the file, it appears to be programmed to continue cutting that low in the file.

Looking at the last few lines of gcode…

G0 Z64
G17
M9
G28 G91 Z0
M5
G28 X0 Y0
M30
%

I believe you are zeroing Z to the wasteboard and at the end of the program it tells it to return to Z zero and then XY zero. So once it finishes it tries to make a straight line from the end point of milling to the lower left corner of the work piece while trying to return the Z axis to zero on the wasteboard.

Someone with a little more expertise with gcode can correct me if I’m wrong.

If I am not mistaken, I think he is referring to to work piece in the top of the picture at the far left how it is cutting a pocket through the material above and below the pyramids. From what I can see, it is in the file to continue cutting lower through the material.

whoa… what the hell? It doesn’t show that in the fusion360 simulation… What gcode viewer is that?

Are those negative z extrusions only on the last 5%?

it’s estlcam. If you were to continue the cut, it would cut to that depth all the way around your pyramids.

all of the red is programmed to cut at that depth

hmmm… all the other flat areas in red are fine, they leave a couple mm of foam… until it gets to that last bit where I stopped it and it starts to freak out…

The lowest Z I saw in the gcode was Z4 which should be 4mm. I didn’t see any negative Z.

I would try taking out the G28 G91 Z0 and retrying on a scrap piece. Once the carve finishes it should raise to Z64 (safety height) and the return to X0Y0.

If that works… I’m not too familiar with Fusion but there should be post processor options and somewhere for you to change the footer of the code to eliminate the return to Z0.

EDIT: Looking at the pictures more carefully…

The top one: It cut out a little triangle in the top left all the way down to the wasteboard and then went down the left side and cut out a triangle in the bottom left?

The bottom one: Top left corner was supposed to be milled down more? But instead it went deep and made one big gouge and then you stopped it or else it would’ve turned out like the top one?

The top one: It cut out a little triangle in the top left all the way down to the wasteboard and then went down the left side and cut out a triangle in the bottom left?

The bottom one: Top left corner was supposed to be milled down more? But instead it went deep and made one big gouge and then you stopped it or else it would’ve turned out like the top one?

both true. it isnt even reaching the point where it goes to z0, it starts going negative at this same point in each job. This is with the generic grbl post processor, tonight I guess I’ll try the easel one, then the shapeoko one, then I’ll just smash it with a hammer probably.

1 Like

One person said GRBL post processor didn’t work for them but the next person said it did. shrug Worth a shot.

Their is a good topic here somewhere on the forum that talks about setting your G28 safe position. Shouldn’t have that problem after that.

g28 is high in z, and far to the back of the machine.

It starts cutting through the wasteboard before the job is complete, before g28 is called…

If you search the forum for fusion 360 and grbl post processor there are a couple complaints about the z axis doing weird things. Hopefully the easel pp will fix the problem.

so, the easel pp made no difference.

As you can see in that code the z axis is pretty much constantly getting worked on this cut.
So I started playing around with my z potentiometer, trying to get this attached file to run infintely without missing steps.

At around 1v, i can get this to run for 8 mins before it misses steps. That’s ridiculously shitty, right? Any lower and its underpowered and skips sooner, any higher and it thermal overloads and skips sooner…

We can’t have constant z movement at a 500mm z feed rate for more than 8 mins straight without it messing up? Would this be improved with the nema 23s? I’ve ordered some heatsinks that I’m going to try and attach to the gshield, maybe that will help. The only other thing I can think of is lowering my z max speed to less than 500mm/m. Shitty. Real disappointed.

test.txt (37.8 KB)

Maybe your z axis movement is too stiff and running into resistance? If you have the acme screw did you run it through the delrin nut with a drill a few times to wear it in? I believe if if you crank down on the 2 screws that hold that nut it will kind of bend the nut and put resistance on the screw.

Maybe someone else has other ideas. Have you tried calling inventables support? I hear they’re very good at helping.

z is pretty loose, I can turn it by hand very easily. I have the normal threaded rod. Would the acme screw improve this?
Part of my is just thinking I should go acme+ nema 23 on the z and get it over with.

I’ve even tried loosening the eccentric spacers so that I can turn the wheels by hand… it still starts missing steps after a couple minutes. I’ve found it lasts the longest just around 1volt at the pot. Any higher/lower and it doesnt last very long.

I’ve redesigned my cam so it has very few z movements, and lowered my $112 to 400. Seems to be working for now, but I’m not very happy about having to slow down do to a machine limitation.

I only have experience with the acme and nema 23. I know I had to turn up the potentiometer on my z when first assembled and it runs warm (compared to the X and Y which remain room temperature). I’ve also never cut foam so I’ve never needed to try and run it that fast. I know I’ve seen other people on the forums say they’ve cut foam and they fly through it.

One example I could find My first real sign

He said 50 inch/min works for him which is about three times faster than you.