Z axis cutting too deep, upgraded kit

I’m having a bit of trouble with my xcarve.

I have the upgrade kit and the z axis is not cutting correctly. It cuts too deep and doesn’t raise when going to the next cut.

Everything it’s screwed in and connected correctly. I don’t know what’s wrong.

Is it possible you need to change the GRBL settings for the new Z axis?

Xcarve GRBL settings - X-Carve - Inventables Community Forum

I actually just figured it out just now. Loose screw on the z axis…. I couldn’t see it when I first checked. Now everything is working!