Z-axis diving into project

I’ve been using my X-Carve for the last 2 months with only minor issues (bad spindle, replaced gshield). Today, the z-axis seems to be randomly diving into my work. Although on my first two projects today, it dove at the end (after hours of work), I reran the “setup my machine” process. This time, it dove after about 10 minutes.

This current project is running a 1/8" flat endmill, 0.025" depth and 30"/min. I ran these conservative settings so that I could try to catch the problem. By the time that I stopped the machine, it was cutting 0.27" deeper than the previous layer. I’ve attached images showing the issue.

I’m running Easel on a new Macbook Pro. My X-Carve is a 500mm unit with the 400w 48v quiet spindle, with the stock arduino and gshield. In scanning the forum, the only suggestion that I haven’t tried is to re-load the Arduino. I can do that, but it doesn’t make sense to me that the Arduino is the problem. Rather, it seems like it may be Easel.

Any thoughts?

Are you 100% sure the bit is not lose and drifting down? My first few cuts I discovered I had not tightened the collet fully and had the same problem; There is a surprising amount of downward force applied to the bit when cutting.

I had that problem, and it was my stock spindle starting to go. Are you using the stock spindle?

also check your z stepper cable, both at the screw plate and the gshield it could be one wire a little loose

Allen, on each of the three failed projects, I was using different bits. One was a 2-flute straight, one was a 2 flute ball ball nose, and one was a 2 flute (pretty aggressive) bit. In the case of the straight bit, there should be no downward force. I’ll check the bit, though, to make sure. By the way, I appreciate all of your posts on the forum - you’ve contributed some really good info.

Brian, I’ve already had the stock spindle replaced and am now using the 48v 400w quiet spindle. It has been working well, so I’m reluctant to replace it if the spindle isn’t the problem. I have been eyeing the DW611, but another $175 is more than I want to spend right now.

I will check the z-stepper cable. It seems to me, though, that loose wires are unlikely to cause a runaway motor. My understanding is that a stepper motor that is uncontrollably “on” requires a repetitive, consistent pattern of signals on the power lines. No?

If I was to hazard a guess I would say you are seeing the results of electric noise from your DC brushed motor. This can cause a stepper driver to send extra steps when it should not. If the machine is mechanically sound then there is a very good chance that noise is causing your problems.


David, thanks for your suggestion. All of my cables to the steppers are shielded but I have not grounded them, yet. The power to my spindle has been kept out of the drag chain though your idea is still a potential. I’ll ground the shielding and also double-check the spindle power cable.

You don’t have to run job to check it. Just turn your spindle on from toggle switch manually, wait and follow your steppers. If steppers start getting irregular pulses, nothing but your spindle is bad. When mine start acting same way, there wasn’t Dewalt mounth available yet, they said any day, took about a month. What I did was, I had another 24V 400W power supply, I wired spindle to that power supply. Used bad spindle more than three weeks with no problem. Last four days I was starting spindle with my finger. But hey it worked anyway.

hi there , did you got the solution for this issue?

It happened four times over a couple of weeks and then seems to have resolved. I think that the bit wasn’t secured well enough in the spindle, causing it to get pulled down while still spinning. It all seems OK now.