Z axis plunge

I’ve tried running a project in easel and vcarve pro. Ive used UGS in vcarve to send the gcode. When ever I get through homing, the spindle comes on and it drives the bit straight down into my wood. Any suggestions on what to do?

Sounds like a zeroing issue. Where is your workpiece zero in carve? And how are you setting zero before you carve?

I’m guessing a post processor issue.

Make sure you’re using a good one.

1 Like

Open the nc-file in a text editor like Notepad etc and paste the 20 first lines or so here, like Justin is guessing I am thinking to this is a PP issue. The snippet of code will most likely confirm than.

Perhaps a G28 position.

1 Like

Nothing before the M3?
Is that from V-carve? What post processor?

V carve and ugs

What post processor are you using within V-carve? X-carve(in)?

Suppose to be UGS. What are some other post processors to use?

The post processor is chosen when you export the gcode from V-carve. It formats the gcode for specific machines. UGS is a gcode sender.

If there’s nothing before the M3 line on the gcode, if go back to asking how you’re setting your Z-zero. And is the work zero at the top of the piece in V-carve?

This is where you select a Post Processor

Here is where you can get one (you need to scroll down to the post processors).

G20 was at the very top if that means anything