Z axis problem with Fusion 360 exports

I have been experiencing a problem with exporting g-code from Fusion 360 for use in Easel and Carvey. All seems fine, but seems to have a z-axis offset. After zeroing zero with the switch, the cut path moves to the proper x,y position but then seems to cut with an offset that seems to be the thickness of the smart clamp. Has anybody else experienced this? Is there an easy fix? Seems the .cps export file may need to be specific to the Carvey vs all Inventables machines.

1 Like

Answering my own question for others who may have the same problem.
Answer: Be sure to set the origin stock point at the TOP of your stock block. If you pick the bottom, then Z=0 is the bottom of your material and is set to the bottom of the clamp. If you pick the top of your stock then z=0 is at the top and therefore matches the bottom of the smart clamp with the top of the material.

3 Likes

I am having a similar problem. When I import g-code from Fusion 360 the x-axis and y axis work fine, but when I run the x carve it doesnt cut to the correct depth. I set my zeros in the g-code and on the machine at the same point at the top of my stock.
Not sure what I’m missing.

@DanielPeace

What kind of deviation are you looking at?

Under your main Setup-folder in Fusion360 CAM do you have “Stock offset” (Top and Side are default)
Under you cut (2D Contour, 2D Adaptive etc) is “Rest Machining” disabled?

The cut was supposed to be 0.25" deep, and only cut about 0.03". My stock offsets are at 0. Rest machining is enabled but the offset is only 0.5mm.

What do the simulation show?
You have the correct Post Processor in use?

The simulation shows it’s working fine. Im using “Easel / f360-easel”. I tried running it again. I zeroed everything manualy to make sure its not the z-probe, and it’s still doing the same thing.

When you import the gcode, does the toolpath look off in Easel?

It looks right in Easel.
I tried attaching the file so you can look at it. Not sure if you can download it or not.
If the file won’t work I can screen shot my setup settings and carve settings if that would be helpful.

Test1.0.nc (328.0 KB)

Gcode looks good (z depth of 1/4"). How are you zeroing?

Here is screen shot of where I set the zero in the program.
I

As far as on the X-Carve I’m doing it manualy right now at the same corner as in F-360. Here is a pic of how I’m zeroing it on my machine.


Not sure if this will work but here is the link to open the actual part in Fusion 360.

http://a360.co/2EwkaM4

Fusion file wouldn’t be causing the issues. Like I said, your gcode has a depth of 0.25in.
As @PhilJohnson asked:

When you jog your Z-Axis up 2in, does it actually move 2in?

EDIT: Just noticed this is in the Carvey forum…we’re talking about an X-Carve though, right?

1 Like

As far as the z-probe I havn’t been using it because it was having problems. Even when I entered the exact thickness It would cut air after I zeroed everything. I think the two problems problems are related, because when I entered a step value of 2" just now and jogged it up it only moved the z-axis 1/2". As far as calibrating the z-axis if you mean in Fusion 360 it defaulted to metric So I just converted the speeds to mm. If you mean in Easel I’m not sure where I would calibrate it.

Sorry missed the part about what machine I’m using. Yes it’s an X-Carve.

There’s the problem…in Easel, go to the machine inspector and type $$. That will give you your grbl settings. The Z-axis steps per mm is stored in the $102 parameter.
Lets say your setting is currently 250.000, you try to jog 50mm and it actually moves 12mm.
Expected/actual*current steps per mm = your new steps per mm.
So, 50/12 = 4.1667. That times 250.000 = 1041.667.
You’d enter $102 = 1041.667.
Repeat the tests until you get it dialed in. I’d jog at least 100mm, and make sure you are measuring accurately and precisely.

1 Like

Thank you guys for all the help!! That seemed to do the trick. Oh and $100 and $101 are for the x and y axis right?

Yup.