Z axis wont move after updating to V. 3.10

so i finally installed my X-controller and after wiring it up i tested it and it worked fine, then after i started up easel it asked me if i wanted to upgrade to version 3.10 (was running 3.7) so i did and now my z axis wont work. X, Y work just fine but not Z. The first time i start up easel i can get a slight twitch from the z when i tell it to go up but then nothing. I bought a new nema 23 stepper thinking thats what it was after checking all the wiring and after installing the new motor still the same issue.

Any ideas or help is greatly appreciated, Thanks in advance.

Check the pot and the DIP switches. Make sure they match the instructions

They do.

swap your wiring of X and Z and see if it works on the X, it could be a bad controller port

i have done that as well. when i do that i can get the x to move but not the z no matter what port i plug it into. it was working fine before the update the only thing i have not done yet is tried reverting back to the v3.7 to see if that works again

Odd, try reverting and see what happens

ill have to try that tomorrow as its to late tonight but as soon as i get home from work ill try that and post what happens.
i usually dont update cause stuff like this happens but the touch plate wasnt working and i wanted to be able to use it which is why i updated and then this… lol

1 Like

ok so after some more testing i installed v3.7 back again and now all the motors spin like they are suppose to so im at a complete loss as to why this happened or what to do so i can get 3.10 back so i can use the touch plate

Quick question, did you update your firmware to the latest f build?

i updated my easel local to the version 3.10 and updated the x controller through easel and thats when the problems started

go to machine inspector and see what versions it says in the top left corner. there should be both the 3.7 and the firmware version

When’d you buy your Xcontroller? About a year ago the shipping controllers had an incorrect v1.0c on them. If you upgraded now, it was to v1.1f and your GRBL settings may have been lost in the upgrade. Post your “$$” output here to make sure they’re right.

it says grbl is v1.1f and local is 3.7

Yes i would say at the very least it was a year ago i bought the xcarve upgrade kit when if first came out but only now had the time where the machine wasnt making something to install it

See what $21 is set to, I wonder if it’s hitting an alarm. Long shot but a simple $$ list in machine inspector will tell us

heres the complete list

Where are you located, it has you set to metric. is that correct?

You’re running version 1.1f

Change $10=1

But this is not your problem. It just takes care of a change from 1.0c to 1.1f

im in the USA. i dont use easel to make my parts i only use it to run the machine, i draw and generate the gcode using Aspire then use easel to run the gcode.

try this type $13=1 in machine inspector and then try 3.10