Z probe wrong height

I just got around to using the z probe I got with my upgrade but when I set the height it starts cutting way too high. Is there a reason it raises up so high after I use the z probe. It works fine if I set z manually.

You have the probe on top of what your cutting and keep the same bit in after you set z?

Did you set the height of the Z-probe in setup?

Hi Brent… likely what Erik mentioned… check this out …

1 Like

So I just had the same issue. Ran through the Z-probe set up, started the cut and the first pass was cutting air. I killed the cut and tried setting the Z-axis zero manually, resent the cut and it still cut air. I will mentioned I didn’t have this issue before the most recent driver update.

Accepting ideas.

By touch plate you are talking about the brass puck? I don’t remember doing that when I got my machine back in Dec, and it has work just fine until today. Is this something that changed with the driver update?


I guess I should have clarified I am a beginner and this is my first CNC.

1 Like

So which set of setting do you want me to post? The ones listed under settings at the very bottom, that look like this

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=4 (dir port invert mask:00000100)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1. (rpm max)
$31=0. (rpm min)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=540.000 (x max travel, mm)
$131=540.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Checked the advance settings for the touch plate. Setting was set to .59, measure my plate at .589in. The gap i was experiencing during the cut appeared to be greater than that difference.

Yep, only the 750mm (if only I had a bigger shop I would have picked up the 1000mm)

No, I will try a reboot next.

I was playing around and noticed that when I zeroed out my z-axis (-0.002) and then sent the cut the z-axis would start is first pass at -0.508. and then step down from there.

Disconnected power from everything completely, rebooted the computer.

Same thing as listed above regardless if i use the touch plate or set the Z manual. Starts first pass at -0.507

After you probe z, try sending it to zero and see if it’s correct.

What do you mean send it to zero? Is there a way to do this in Easel without being in a project?

Well…sorry for the headache. I appreciated all the help though. Guess I will either have to get used to the variance or consider leveling my waste board.

1 Like

I assume there is a post on here that details that, right?

Not yet. Honestly that is the first time I have gone into the grbl. I know who to contact now when I decide to make the switch.

1 Like

Hi there, just wanted to add that I had a similar issue in effect. I checked everything from this thread with no avail. The issue I was having was my poor understanding of registration points in Fusion 360. I had the z registered on the bottom of the work where it should have been at the top of the work. This article led me to look at the nc file where I noticed all the z calls were positive. When you think about it, if you register Z0 at the top of the work using a probe or manually and your program is all positive z heights it makes perfect sense why you’d be cutting through thin air. Hope this helps someone.