Can't connect my xcarve

I am physically sick to my stomach with frustration at this point… For the moment I have given up on the problem of my xcarve cutting circles, as it can cut straight lines fine apparently. So I went to run a job and the spindle didn’t turn on, so I stopped the job and looked for the problem, the wire going into the powersupply had gotten loose. no problem. turned it off and reattached the wire. Turned it back on and went to re zero my xcarve and low and behold it wasn’t reconnecting to chilipeppr. I’ve had issues before and just restarted my computer and that did the trick. So upon doing that I reloaded Chilipeppr and it was saying my machine was offline. Yes it was turned on and plugged in via usb. I jumped over to Easel and tried to setup my machine from there and it wouldn’t find the port. Went to system and hardware settings and arduino is connected to 3 as per usual. I’ve reset everything 3 or 4 times and can’t get a connection between the two. Any ideas? Yes I checked all the connections, yes I have the chilipeppr server running.

We were discussing similar issue on following link. You may want to take a look at it.

i would love to rid myself of the headache known as chilipeppr. Unfortunately I can’t get UGS to run for me at all, I installed java and when I hit the start.exe or whatever it just opens for a command window for a sec and closes. I would love to not have to connect to the internet to run my machine

@AlanDavis but also my main issue here is that I’ve done hours of jobs using chilipeppr and a few hours using easel. the fact that i can’t connect to either right now leads me to believe it’s an issue with the connection to the machine, I just don’t know what that could be

UGS gave me same problems at the beginning, all related USB port issue. Purchased externally power USB hub, now working like a charm. PC/Laptop USB output have not enough power. I made it stronger.

1 Like

but that still doesn’t answer my question. I can’t even get to any semblance of a operating screen with UGS. it doesn’t open period… I don’t know why no one can help me out with that…

When you connect your X-Carve did you see if there is Com port assigned to Arduino on Device Manager. If it’s there, unplug, wait couple seconds then plug it back again to see if any problem reading Arduino.

with all due respect @AlanDavis I went over this in my original post.

Which version of UGS you’re trying to open.

i believe it is 1.08

Would you like to try loading 32 Bit Java manually. As far as I know 64 bit having issues if Chrome is your default Web browser. Can see chrome kicks back.

Use version 2.0. I could not make 1.8 open either

i saw your post earlier regarding 2.0, i can’t seem to find a download link though

@AlanDavis how do i go about loading java manually?

could you share the setup file via dropbox or drive?

First, are you using the latest version of UGS?

Second, it is weird that ChiliPeppr was working and now it doesn’t.

Are you using the USB cable that came with the X-Carve?
Is your X-Carve plugged directly into your PC?
Is it the only USB device plugged into your PC?

If it is a problem on the software/PC side of things then answers to these questions might help.

Also, does the machine work with Easel and just not the others? (531.9 KB)

as stated, i’ve ran jobs with both easel and chilpeppr and at the moment can’t get it connected to either. yes to all of your questions.

@AlanDavis thank you

Here is the link to UGS 2.0