Machine not returning to work zero

My machine is not returning to work zero after carving, it homes ok and then goes to work zero when I press G28, then carves perfect circles but does not return to the work zero G28 position, it seems to go back to work zero when I carve large circles 6" or more but not small circles 3" or 4", it also will not carve text , it carves one letter on top of the other, it is calibrated and jogs perfectly

G28 is not related to work zero.
G28 (and G30) is a user-defined, arbitrary point within the work range of your machine.

G28 can be used as a parking spot, preset, for work zero position, often in conjunction with a bump stop of some sort.

What is your work flow?
Programs used, straight-up Easel or other software?
Please include a gcode file where the carve do not return to work zero.

1 Like

3.gcode (7.7 KB)

@PatrickDunne As @HaldorLonningdal said, G28 is not work zero.
Your gcode is sending the machine to your work zero. I suspect your work zero is not where you think it is.

Can you send $# through the machine inspector and paste what it returns.

In Picsender, what is the reported work coordinates showing after a carve?

Me 2.

I forgot to mention that I got a new stepper motor for the X axs ,it’s a Nema 3450z 3.0a, I have just tried jogging in Easel, jogging 1" in Y and Z it travels 1" but in X it just jogs about 0.1 do I need to adjust steps per min

@PatrickDunne How’d you carve a 3" circle with an X-axis that’s off by a factor of 10?

Anyway, to calibrate steps/mm (number of steps the motor takes to create 1mm of travel):

1 Like


Okay, thanks for that Neil, I will have to leave it for tonight but will try adjusting the steps in the morning, it jogs okay in Picsender

A few things:
My suspicion was wrong, your G28 is at your work zero. Unless you’re working on a different WCS. How far off of zero is it? About 4.67mm in X and 9.83mm in Y?
Just changing the motor shouldn’t affect your steps/mm.

Can you get all of your $$ settings and paste them (those are the $1 - $132 values)?

Paging @picengravertoo and @LarryM.

Contact Jeff through for support help.

Data sheet on that stepper?
If all you changed was the stepper and both the old one and the new one is 1.8deg/step (200step/rev) there should not be any scaling issue.

1 Like

The stepper is a drop-in replacement so should show no difference with the same settings.

Can you do a 6" and 3" carve using Easel only?

Thank’s Haldor, I will check if I can do that in Easel when I get to the workshop and report back

Can you get all of your $$ settings and paste them (those are the $1 - $132 values)?

I have tried cutting the same circles in Ease,l and have the same problem 6 7 and 8 inch cut perfectly and returns to home zero, but 2-3-4 and 5 inch do not return to zero, it returns to the correct point in the Y direction but is off in the X direction, and the amount it’s of varies according to the size of the circle
5" off by1.75"
4" 0ff by 1.75"
3" off by 3"
2" off by 3.75"
jogging in EaseL Y and Z move what ever distance I input, but X only moves about 0.01 whatever I input
jogging in Picsender is perfect on all axis

$120 is very high at 5000, derate it to 200 for now. Do the same for $121.

Acceleration set too high will cause missed steps.

1 Like

Than’s Haldor, I dropped $120 and $121 down to 200 and I also tried 100, but that did not make any difference, so I have it at 300 for now

Your experience do not make much sense (yet?)

Are the circles also designed in Easel or imported?
By testing within Easel (from design to carving) we can rule out post process issues.

Can you export the gcode files for both 8" and 3" circle and post the files here? Not as text import but file import.