Inventables Community Forum

Multiple depth carve

I’m having a hard time keeping zero when changing bits and adding or removing the dust boot.
Everytime I change the bit it causes the drill to move. Even when adding or removing the dust boot, the drill will move. I have tried the switches inside that I was told by support would lock the motors but didn’t.
I’m carving the first step with a 1/8 bit and the second with a 1/16 it’s always off after a bit change

1 Like

Do you have the X-Controller? If you do, you should open it up and check the Dip Switches for each axis. Dip Switch 4 should be set to the OFF (Down if viewed with numbers on bottom or left in the image as shown) position as shown in the image below.

Capture

You will also need to ensure that parameter $1 in the GRBL settings is set to 255.

{:0)

Brandon Parker

Yes have tried the switches inside that I was told by support would lock the motors but didn’t. It still moves.

Did you check parameter $1 in your GRBL settings?

  1. Go to Machine>Advanced>Machine Inspector
  2. Check the settings by typing in $$ in the Console box and pressing the Enter key, if $1 is not 255 then perform step 3
  3. In the Console box, type in $1=255 and press the Enter key

{:0)

Brandon Parker

Just perform Step 3 above, and then issue the $$ command again to ensure that $1 was changed to 255.

{:0)

Brandon Parker

I did it but what does that do?

What are the steps in between workspaces to get it lined up for the next job?

Changing $1 to 255 tells GRBL to provide the maximum amount of current to a stepper that is holding in place after a motion command.

Since the 4th position of your Dip Switches is set to OFF, having $1 at 0 means that GRBL shuts OFF power to the steppers after motion commands are complete.

If this does not resolve your issue, you would have to check the potentiometers that set the current to any axis that is moving. I highly doubt you will need to do that though …

{:0)

Brandon Parker

After the “Roughing Pass” completes, the machine should return to the Work Zero position. You would then just need to change the bit, zero the Z-Axis again, and then start the “Detailed Pass” …

{:0)

Brandon Parker

I completed what you said to do. Then followed these steps.

  • Clicked the home button.

  • Clicked the carve button.

  • Put the dust boot on and it felt sturdy now.

  • Did the probe under the dust boot

  • Started the carve

I will repeat this for the next bit change

Do you have homing switches installed?
If so, do a new homing cycle after changing bits, reset Z only and use “Previous Home Position” setting in Easel and you are good to go :slight_smile:

Here’s what I do.

2 Likes

I use three C-clamps to hold everything in place, including pressing the button on the router. I found that I was trying to use to much force to change the bit and would “Push” the router slightly.

Brilliant to use the touch plate to find zero in all 3 axes!