Need help tried getting picsender to work for jtech and lost easel

Had the machine running fine with Easel after new garage computer hard drive and reinstalling it all. Tried adding pic sender so I could run the laser with on off commands since I have not had any luck with easel for that and thats where the problems started. I lost connection to easel and after reinstalling easel local it came back until I connected to pic sender again and this time easel wont connect even with reinstalled grbl. I could not get pic sender to run the quick test file I made until flashing the xcarve with the jtech grbl and now picsender sends the file but when I jog the machine seems left and right are backwards and when I run the file it does not control laser on off and just makes a diagonal burn from bottom left to top right and I have to unplug USB to make it stop since I assume it will go beyond the machine limits if I let it continue. I still cannot connect to Easel and setup my machine. I have no clue where to go from here to make either one work now. I can connect the the machine with xloader and picsender and it shows up on COM5 on the computer but Easel is now useless and picsender doesnt seem to function correct.

1 Like

Quick Engrave 1.gcode (18.8 KB)

1 Like

Also noticed the machine bumps the motors every 6 seconds with no software connected to it when it bumps the 3 green lights on the board flicker ever time it bumps. I just uninstalled the device in the device manager then reinstalled it and still no easel connection.

I just sent that G-code file to my test system with PicSender 2.7.4 and UGCS 1.0.9 and did not have any problems with either sender. No errors.

Do you know how to use the Arduino IDE serial monitor?

1 Like

no clue I also downloaded the new GUI version of UGS which is a nightly build and it connects and sees the Arduino but cant seem to get it functioning right either

I just tested your gcode file with PicSender & Larry’s MultiMode grbl 1.0c also and it runs fine.

I suspect the issue your having with connecting to Easel is, your grbl settings are not set correctly for it. With two LaserMode versions of grbl, PicSender changes the grbl settings automatically based on which Mode (Spindle or Laser) you have selected, but it needs to be setup properly.

Without knowing what version of grbl your using, it’s hard to help you get this resolved.

If you do not have Larry’s grbl flashed to your controller, I suggest you do so. The hex download is here:

There are setup instructions for PicSender & the grbl settings here:

The two grbl setting text files are in C:\ProgramData\PicGRBL for manually editing them in a text editor like Notepad.


I keep seeing talk about settings and saving and changing and I have no clue where any of these settings are or are supposed to go. I downloaded larrys grbl but now xloader is saying cant connect to port

Reading that 2nd link now hopefully figure out what and where to change but I still dont understand how or why I lost easel

Closed the web browser and xloader was able to connect maybe I had an easel tab open I have no clue but new grbl appears to connect and work better now I will try the test file again

Here is information on what the individual grbl settings do and how to configure them.


For some reason the laser is always on no longer seems to be controlled by the pwm but i manually turned it on and the test file made the first letter only which I assume is because its the trial version? Is the laser always on when turned on because I need to change settings or is there something wrong with the laser possibly since easel no longer turned it on or off with spindle control when it was working? Last summer I ran a test file and the laser was doing on and off through easel as spindle on off but since I had it out the last couple weeks once it warmed up here enough to play it is always on when switched on

There is a switch on the laser control board that selects CW (continuous wave) or PWM control. Make sure that switch is not set for CW.

1 Like

It was, must have bumped it. Thanks Larry on less problem to solve

scratch that the laser does not turn on now with laser or spindle selected in picsender

If you have removed the power from the laser you must hit the reset switch for it to work again.

So to use picsender safely I need to change files somewhere with the spindle laser control peramiters and soft limits for a 1000mm machine. I have no clue how to do either or where this is done still. I see the file posted by Lary but it says 500mm machine so I assume the soft limits will be wrong and is this something that only needs to be done in pic sender or do I need to set soft limits in easel somewhere because of the jtech grbl killing my homing switches? I guess once I get pic sender all working they way it should I will worry about easel connecting after since I would still like to utilize it as well

I did reset it and its on when switched to CW but no control through pwm for some reason

Here are the settings that I use for testing the laser code with my 1.0c

Some of them will be different for your machine,

How do your settings compare to these?

$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=18 (status report mask:01110011)
$11=0.005 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255. (rpm max)
$31=0. (rpm min)
$32=1 (laser mode, bool)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=7650.000 (x max rate, mm/min)
$111=7650.000 (y max rate, mm/min)
$112=2540.000 (z max rate, mm/min)
$120=8000.000 (x accel, mm/sec^2)
$121=8000.000 (y accel, mm/sec^2)
$122=150.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=88.000 (z max travel, mm)

where do I find those settings?

In the Demo, the GRBL menu is disabled, so you need to make the grbl setting changes in

Select the $$ button.

1 Like