Possible bug in easel pro: 'use last XY home position' on finish pass = failure

I recently did a two pass cut in easel using a 1/4" bit for the rough, and a 1/8" bit for the finish. It turned out pretty good:


I decided to try another design, but this time use Easel Pro, so I could use a 90 deg v-bit for the finish pass (1/8" on the rough).

It turned out better because of it (the v-bit putting a nice chamfer on things), however, here was a pretty major failure involved I wanted to report here:

Both projects were nearly identical, other than the fact I used a V-bit for the finish pass on the second one, and thus was using ‘easel pro’ on the second one. The 2nd project was about half the size of the first, but I doubt that has anything to do with this.

The failure was on the finish pass of the second project: When I went to swap from the 1.8" endmill to the 90deg v-bit, I re-homed my z axis using my probe (just like the first project) and selected the ‘use last XY home position’ for it (just like the first project). However, when the finish pass started, the gantry shot to the left front corner of the xcarve, causing the steppers to start skipping like crazy until I was able to hit the pause button in Easel.
From there I restarted it, having to manually home XY, guessing where I had done it for the rough pass. I was about 1/16" off, and thus had a bunch of sanding later.

But obviously this shouldn’t be happening, and I presume its a bug. And I’m a bit scared to try a finish-pass with a V-bit again because of it. Despite the fact that if it works correctly, it puts a great edge on the cut.

Thoughts/opinions/advice from users/Inventables crew?

Do you have homing switches?

I do not have homing switches: Well, when I first built by x-carve (2+ years ago) I had them hooked up, they worked one time, and the just sort of ‘died’. Which freaked me out since as also a 3d printer user, they’re absolutely required. But I learned they’re actually not needed at all for CNC (not that they hurt if functional) and never got them working again.

However, for any other project I’ve said ‘use last xy’ on a finish pass it’s worked fine, so something is definitely amiss here.

If you home your machine and use a bump stop and or g28 you are able to recover your x, y zero reliably.

1 Like

True that.

Regardless of how I can home / recover though, this just feels like a bug in the software.

I would think the forum would be full threads if there was a bug with two stage carves and use last home position. That being said easel is full of bugs that come and go. Did the screen come up that asks you if everything came out OK?

Easel saves the work zero position to the controller’s persistent memory (eeprom). Any workpiece position is essentially an offset from your machine position. Without homing switches, your machine position is arbitrary and so are the offsets. If your controller reset for any reason, your new machine 0,0,0 is where your router currently is. Any offset will be based on that position. If you plan on doing carves with tool changes, you really should have homing switches or 3-axis probing. Not discounting the possibility of a bug, but I’d guess your controller reset after the roughing pass.

1 Like

@ChrisRice : After the rough pass, yes, that screen comes up. Just like it always does when doing 2-part cuts. Nothing to alert me anything had gone wrong.

@NeilFerreri1 : Good info : I’m sending the data from my laptop over usb to the arduino: So even if there was a power failure to the house, the laptop (and arduino) are unaffected. I agree that a controller reset would cause this, but the whole cut only took half an hour, I was there next to it the whole time, I saw nothing of the sort.

Basically, I’ve done many two part cuts in easel without any problems at all. The very first time I try it with a V-bit on the finish it wigs out,… it just seemed like more than a coincidence. But maybe not, maybe it just glitched.

I wished my homing switches worked: If we go back in the forum posts two years ago you’ll see me trying all sorts of stuff to get them working, but they never did: Totoally stock setup at that time from the factory: First time it homed, it worked, once. After that, it was like they never existed, despite me rewiring them into the arduino, and checking connectivity on each.

1 Like

Like I said, I’d never rule out the possible bug. Can you try to see if the issue is repeatable?

Use Pin12 for Z limit switch. Many diagrams on the net showing Arduino pinout show Pin9/10/11 for limit switches. Pin 12 is now Z-limit and is the first path the homing sequence will perform. If Z fail X/Y won’t attempt homing. I recently added homing to mine, with direct connection to the Arduino and it work very well.

@NeilFerreri1 : I suppose I could re-run the whole thing with no bits and see if it does the same thing: That would probably prove out if it was a reproable bug, or just a glitch.

@HaldorLonningdal : Thanks for the info: I’ll check to see how that stuff is wired if (but I think I disconnected it all at some point, since it wasn’t working)…

I ran the cut again (no bit \ stock) : The transition from rough to finish went fine. So this definitively falls into the ‘glitch’ category. But still scary, since I don’t know what caused it, or if\when its going to happen again.

@HaldorLonningdal : I confirmed that my wiring is correct based on what you said: It was like this from day 1.

I have a spare smoothieboard laying around, so I may eventually just swap over to that and see if I can get the endstops configured that way.

I dug up the old thread when I was trying to figure out why my switches weren’t working. After much troubleshooting, it came down to ‘maybe you have a bad arduino’. Replacing that may be easier than a whole new smoothieboard, once I find some spare time :wink:

1 Like