Inventables Community Forum

Rapid collision with stock

still working on getting my first 3d-carve with fusion.
My first problem was solved by reading this: Fusion 360 z offset

However when I tested carving my fusion object, it worked perfectly untill right before the end, when suddenly it started drilling right over my material in a path I never had. the bit was completly down in the whole material of 1.9 cm. Looking at fusion simulatio I see something called “rapid collision with stock” and I wonder if that’s the reason. I have tried to eliminate these collisions, but i can’t seem to shake them off. any ideas?

Ah, I’ll bet it made something that looked just like this! All the way done, pulls up from the last move, then BRAAAAAAAAWP, right across the stock on a straight-line path, in a direction you didn’t specify, to a depth you didn’t order.

It took me a darn long time to figure this one out! I’d bet money that your G28 home is set somewhere random. The last move in a Fusion program, by default, sends your machine back to G28. That move is regardless of safety height and everything else, it’s a direct move.

To make my suggestions more useful, do you have homing switches on your X-Carve?

1 Like

thats exactly how it looks!

My machine is the carvey. but I see it reacts to $H to start homeing-procedure if thats what your thinking off. Totaly new to all this :slight_smile:

1 Like

Ah, then I know what’s going on, to about 95% certainty, I’d guess!

You need to set your G28 home. There’s a ton of good information on the forum here about what comprises G28 and different ways to use it. To simplify for you into just what you need to do to make it stop doing horrible things to your projects:

Fire up the Carvey, and send your homing command. When it’s homed, go to the console of whatever G-code sender you are using (easel, UGCS, CP, etc) and send “G28.1” without the quotes. That will set your G28 home to the same spot as your machine home. After that, each project you run from Fusion will move to that spot at the start of each run, and return to that spot at the end of the run.

It is critical for this that you home your carvey each time you start it up, before you run a project. You will only have to do that once each time it is power cycled. When you start the run, don’t be alarmed when your first move is not necessarily in the direction of your first cut! It will go to the spot you set as G28 home (the same spot Carvey homes to, if you use the steps outlined) THEN it will move to start the first cut. At the end of each run, it will return to the spot you set as G28 home and turn off the spindle.

Congrats on getting going with a new machine, man! :slight_smile:

2 Likes

Will you add this to the Fusion 360 tips forum? Thx.

And can be the biggest range-inducing face-desk things in the world when you don’t know about 'em! lol

G28 and how it relates to F360 drove me absolutely nuts when I was starting out!

There is now an option in fusion 360 (at least in the generic grbl post processor) to turn G28 off.

1 Like

Many thanks for explaining this. I have tested it now, and perfect. no destroying near the 100% of job :smiley:

Still got a way to go before good results.

My first sign. The deep cuts in the design is me trying a engraving bit (failed…)


30Degrees

The rough finsh is done with a ball end 1/8. Quite happy with the rounded finish:

Here is how it looks in fusion:

Struggling with engraving the design.

Hey, that’s coming out nicely! I’ve had my best luck with V-Carve using a 60-degree bit, myself. Seems a good blend of fine-line and wide-line capability, without getting too crazy deep. I’ve had little to no luck engraving in Fusion with the engraving paths, it just doesn’t work well for me. Or, rather, I haven’t figured out how to MAKE it work properly yet. Generally, I use Fusion for all my functional machining, and V-Carve for machine engraving.

Glad that worked out for you, and congrats on a mostly-successful project! That’s 95% of the way there!

As a rule of thumb, every time i set my work zero i move the Z axis up about 30mm and set g28.1

1 Like

If you don’t have the homing switches where you can have it set automatically, that’s a great way to do it!

I hadn’t thought about using G30 that way, I’ve always just jogged it back a couple times with the 10" setting. I’ll have to set that, that’s a great idea!

1 Like

Makes sense. My G28 is always set at the X0Y0 of whatever fixture I’m using, with Z homed (all the way up), then backed down ~5mm just to make sure it doesn’t go into the switch at the end of the job if the motor has somehow lost a couple steps.

Seems like that’d be an easy thing to add to the post-processor, just a last two lines to go to G28, then G30.

1 Like

any chance someone got some tips here:

my machine is out of commision. the thing can’t hit the height detection button longer…