Rerun Easel Setup for X-Carve

Jeremy, I am pretty sure you have either a loose wire or a bad USB port or cable.

Easel Set Up a bust for first four tries, I have checked all my wires the motors are getting current so is my spindle yet, when I go to run my machine in the correct com port under set up it just gets stuck on the screen. Is there anyone else who is running into this error in Windows 8?

Cris

A few things you may want to step through:

  • Are you running Easel and UGS at the same time?
  • try different USB port
  • double check that the gShield is seated firmly into the proper pin hole in the Arduino
  • turn the voltage pots on on the gushily up just a small fraction

maybe one of these will catch the issue… otherwise at least they will be weeded out.

I have to reinforce @sketch42’s third point, I had the same problem as you on my initial setup and it was my gshield not sitting correctly in the Arduino, I had to unscrew the arduino from the mount to get it to seat correctly. Good Luck! I hope you get it figured out.

James

When Easel is on the setup screen where it says “Connecting to X-Carve,” all it is doing is trying to open the specified port (on Windows, that is–on Mac it automatically finds an Arduino port), then look for a response string from the arduino that identifies the controller (typically “Grbl [version]”). If it can’t do either of those things (open the port, see the proper response), then it will be “stuck” on this step.

If it’s stuck, we have to diagnose which of those things is failing. What I will usually do first is to close my browser and try connecting to the port from Universal Gcode Sender. For grbl 0.9 you have to connect at 115200 baud. If you don’t get the “Grbl [version]” response after opening the port, then there could be a few possible things wrong: grbl not properly flashed to the arduino, system not recognizing the arduino properly (drivers not installed?), hardware issue, etc. If you do see the “Grbl [version]” response, then Easel should be able to connect as well. It could be a possible port conflict (Easel can’t open the port because something else has the port open). The software team might have to take a deeper look at your log files if you can consistently connect from UGS but not from Easel.

1 Like

JeffTalbot- thank you for the feedback and help. I have now been able to get the UGS to connect and open. It reflects the ‘Jtech grbl’ is loaded. I will now try to get to the easel set up to see if that will reset the grbl.

X, Y, and Z green lights flash but nothing further happening. ‘Stuck’ back on the com 3 view. any other thoughts? Thanks!

Easel cannot connect to it if says “Jtech grbl.” Easel setup cannot flash the arduino. On another thread I posted a link to the wiki page explaining how to compile and flash grbl to the arduino. Did you follow those steps?

1 Like

I watched the video discussing loading grbl to the arduino software. I removed my arduino files and reloaded them. There is a library at the bottom indicating grbl. I still went ahead and downloaded the latest grbl from github.com and attempted to add it as a library. of course it already has a grbl. I then went back to easel to see if it would do anything different. No luck. I went back to UGS and determined the JTech grbl is still loaded. so apparently I did not follow your guidance very well. I will go back and review…

Here is the link that documents the process I have used to compile and flash grbl. Note that at the beginning it says “NOTE: Before starting, make sure that any older installation of Grbl has been completely removed from the Arduino IDE.” I’ve never had to remove a previous installation from the IDE, but try looking for a button or menu option that clears the jtech library out before adding the the 9i one.

Thanks. At this point, I have been able to confirm that I seriously don’t know what the hell I am doing with arduino, grbl, IDE, etc etc. ughhhh. Of course I am trying to drive through completion of a project so the frustration just drives quicker. I need to get the laser to work today (primary goal at the moment) and then return my system. My consideration was to get the system back to normal and see if I could start over with the other process. I will just keep beating my head against the machine- at least it moves that way!

Success! I went to http://www.shapeoko.com/wiki/index.php/Grbl#Shapeoko_2_Hex_File and downloaded the SO2 hex. I then used the Xloader to upload the hex file. After that Easel was able to connect. Whew! Thank you again JeffTalbot for your help!

Well it sounded good. Easel moved past the COM port check but had no control over X,Y, or Z. I will keep at it…

I was able to get the compiling grbl to work and now have X,Y,Z control! so far so good.

1 Like

Hey Jeremy…did you ever figure out how to reflash the right grbl to the arduino? I can reflash w/ the Xloader but none of my XYZ green lights lit up and then when the g-code runs, the machine runs to the far left like the scale is off by ten times. This all started when i loaded grbl 8…to make it work w/ UGS…which it did, now I can’t reload 9i for x-carve to work right.

I did. I am not sure that I did the text book fashion of doing this, but I was able to recover the hex. I followed the details at:
https://github.com/grbl/grbl/wiki/Compiling-Grbl and https://github.com/grbl/grbl/wiki/Flashing-Grbl-to-an-Arduino

I deleted my arduino software and reloaded it in one instance and then went through the process listed in the links above. In another instance, I was able to use Xloader to upload the hex found at:

There are some additional details at this string:

Hope this helps…likely too much info but this has been an interesting adventure for sure.

V/R
J.R.

Thanks for posting this! The inventables X-Carve Pro instructions just say to go to easel.inventables.com (which does not prompt the install)

False alarm, http://easel.inventables.com/setup doesn’t have any setup or calibration. Does anyone know how to finish the final steps of the install for the X-Carve Pro ?.. Installing the waist board and squaring the machine?

This is the page with the instructions. Please give us a call 312-775-7009 and we’ll help you through it.

Hey Zach,

Unfortunately those instructions are a dead end. When you click on the link to go to Easel and select your machine, it connects and the only option is to hit Finish or Test Cut. No instructions on installing the waist board or calibration the Y2.

I’ll try the phone again…