[Resolved] EASEL NOT CONNECTING ? I'm a damsel in distress , who's tearing her hair out!

PLEASE PLEASE ,HELP!!! oK, THE STORY SO FAR… We, as in hubby and I finished building the xcarve 1000 fully loaded yesterday , and so looked forward to starting our new hobby. Little did we know :confused: anyway as I’m the more computer literate I got the job of setting the computer programming up . I’m definately no expert but can get round the ins and out pretty well. After following all the instructions , downloading the Arduino Uno , updating the driver, and Easel program I got to the Homing sequence . I was using a laptop , running Vista on Chrome . Everything went fine the spindle moved to the homing position and I got up to the point where I was ready to do my test carve . Unfortunately as it was rather late and we have built the xcarve up on the dining table I had to wait until today to carry on .So this morning I kicked everything back up again only to find that Easel wouldnt connect and said it couldnt find the XCarve??? I had the blue light and 3 greens but nothing , and no “click” when trying to connect like the night before. I cant even re home it as nothing is connecting. I have tried using different usb ports but nothing, a different laptop but still the same . The second laptop I tried was running Windows 7 on Chrome. The Arduino UNO is showing in the ports/ com on COM7 , and its saying that the driver is uptodate. It was installed using the Windows installer /Nullsoft Install System v2.46. Easel driver is 0.2.5, node v2.2.86 . Easel Local is setup. The only thing is couldnt do to the instructions was update the driver via the stated folder ( arduino.inf ), as the operating system did it automatically, but it says if I try and update it that it is the up to date version that it is using. I’m soooo gutted ! and disappointed with it and not being able to solve it . So , please here my cries !!! lol . There’s a huge virtual hug and kisses ready to cross the airwaves if you can help :kiss::kiss:

1 Like

Make sure you don’t have more than one Easel window open.

Make sure that when you connect the USB cable you hear the tell-tale tone that a device was added and if you have device manager open when you connect the cable you should see a new port pop up.

Does the device show up as healthy in device manager?

I would recommend going back to the laptop that first worked and load the Universal Gcode Sender (UGS)
you can find it at http://bit.ly/1hftIhy

It is a Java program so it will expect you to have the latest version of Java loaded

You start UGS by just double clicking the JAR file after you have unzipped everything into a directory you want it to live in.

Once you get UGS running you can connect to the X-Carve with UGS and be sure everything is working normally on the X-Carve.

When running UGS be sure that Easel is not open in any browser or any browser tab,

The Baud rate you should set in UGS should be 115200 if you are running the most recent version of Grbl, if you have an older version of GRBL 9600 will work.

I’d go with the trusty restart on the computer, Windows can be funny like that sometimes. Is your Com set to the correct one within Easel?

Make sure that the G-Shield is full seating in the Arduino and all your wire connections are secure.

Hopefully you get it sorted!

Hi Darryl , there is no conflicting sign in device manager and I hear the sound of new device when I plug the USB in ???

Sorry Allen, that’s just gone straight over my head . I’ve no idea how to use UGS and Ive never used a cnc machine or program before .

Hi Rusty , how do I check the com port in Easel ???

When you go to the Carve button it should say can’t find X-Carve and have a spot for the com number, make sure that is the same as the com number the Arduino is in Device manager.


Maybe this post will help

Connecting to X-carve

There is a known bug in with windows 7 machines

Hi again , this is what I see when I click on Carve. There is nothing re: com port ? Only bit missing of the pic is at the bottom it says do I want to send in a diagnostic ?

Is there more than 1 USB port on the machine? I’ve found that even though you hear the sound of a device being added, the machine still won’t show up, but unplugging and moving the USB cable to a different USB port makes all the difference.

I have 2 USB ports on my laptop that I use with easel, 1 port works great, the other port will make the sound but never connect.

Make sure to try all the USB ports if you have more than 1

Hmmm, I thought it used to be there, maybe try running the machine setup again (under Machine menu item).

Did you at any point load another program onto the Arduino? I know there had been a couple people who have made that mistake.

I just got my Xcarve built last week and had a very similar issue. It seemed to connect first time, but then could not recognize it. I uninstalled Easel local 0.2.5 and then installed the older version 0.2.2 as mentioned in another post and it has been working ever since. I would definitely give that a try.

Ive moved back on to the vista laptop now , and have tried 2 of the 3 usb ports to no avail .

Did you get the arduino that inventables sell, or did you buy a clone?

Another thing to try is to go to Arduino.cc and download the latest version of the Arduino ide. That will install the latest drivers for you.

oooh that might be an idea . OK , so do I delete the Easel program currently installed first or can I override it ? Do I get a choice which to download then from the installation instructions ?

Just make sure you don’t open it up and load the blink program!

Hi BradT, I used the link on the installation notes to get the Arduino UNO.

lol funny , as if I know what that means lolololol

I don’t have much hair to pull out, but I went through the same thing. Read lots of advice from the community and my problem turned out to be my Ethernet cable. I was using an old one and one out of every ten tries I might get a connection. Replaced it with a brand spanking new one and it connects every time. If you are using a WIFI connection, I would guess that might be your problem. Get a long CAT 5E or 6 cable and it might take care of your hair problem