[solved] SVG Import Scaling Issue

I’ve been having issues with all of my svg files scaling down on import. No idea why, my file in iDraw is the proper size, when I export the file the scale is set to 100%. Here is the link to my Easel project, the outer most circle should be 63mm and the internal square should be 41mm x 41mm. This is really baffling me, not too sure what else to do.

For .svg files, there’s a setting in the file which governs the rendered resolution of the files — the MakerCAM page notes:

http://www.shapeoko.com/wiki/index.php/MakerCAM#Preferences

Most notably, it is necessary to set the scaling of imported files using Edit | Edit Preferences to access SVG Import Default Resolution (px/inch) — 72 for Adobe Illustrator, 90 for InkScape.

You can open a file and examine it in a text editor to determine this setting (if it’s present). If Easel doesn’t have an option for adjusting on import you can use math to determine the correct scaling and either do it in Easel or in iDraw.

Hi Rusty,

The problem is that SVG files have no real-world scale. Easel relies on a combination of smart defaults and exported header files. iDraw doesn’t export SVG files with any kind of header that allows Easel to detect the DPI automatically. For now, you would need to compensate for the scale using from iDraw by making everything 133% scale. I know this is not a good solution, sorry about the inconvenience. I think a solution like @WillAdams suggests, allowing you to manually enter the scale, is a good solution.

I’ll keep this thread updated when there are changes.
Paul

Thanks for the reply! I looked in iDraw and couldn’t seem to find the render resolution settings, or any information in regards to that. It also doesn’t look like you can change the import resolution in Easel.

Like @paulkaplan said, I was able to get my file to import properly by scaling up my export (133.3% got me to my exact dimensions). This isn’t the end of the world, but it would be nice to have some more information from Inventables on importing svg files into Easel.

I also opened the svg file in a text editor, but I wasn’t able to find the resolution of the file, I probably just missed it though.

Glad that worked for you (temporarily at least).

That is actually the problem. It is implicit in the “pixel” size declared. But every editor uses its own pixel -> inch ratio! We get over this issue with inkscape and illustrator because they put a little header declaring what program the SVG was made in. iDraw doesn’t do that.

OOOOH, that makes more sense! Thanks for the info, eases my frustration when I kind of know what’s going on! If all I have to do is scale my svg files on export and I get accurate dimensions, that works for me.

I might in the future get a copy of Illustrator, but for now I’ll use what I got!

Thanks for the help!

I was using iDraw a long time ago for laser work. Never understood why it’s SVGs were always scaled wrong. Now I finally do!

Ya this was driving me nuts! Having to scale my export isn’t a big deal, I just need to remember to do it! The reason this happens is actually an issue with iDraw, this is the response I got from Jim on the Inventables team:

Easel tries to detect what app the file was saved with, and use the value from that app—but iDraw doesn’t leave any signature in the file, so Easel uses its default scale (96ppi) instead of being able to use an iDraw-specific scale (72ppi).

Now I’m off to re-export off my projects, and patiently wait for my X-Carve to show up!!

Glad I found this thread, this has been driving me nuts!

I’ll put in a request to iDraw to see if they can add the header.

1 Like

A post was split to a new topic: Circle carves too small