[Solved!] X carve cutting the right shape, but in the wrong location

I just got my machine up and running. I’ve been doing simple tests–cutting circles and squares. It cuts the shapes perfectly and to the exact dimensions they are supposed to be. The problem is that the shapes are being cut in the wrong location on my work piece. For example, lets say I have a 10"x10" workpiece. I draw 3 circles near the top edge. When I run the job, the cuts get made toward the bottom edge or middle of the material. I have tried several different projects, all new projects drawn in Easel, all being cut in the wrong location. I have re-homed and re-zeroed my machine each time prior to running the job. I have restarted my computer (Macbook Pro) five times. Also, when the jobs finish the spindle does not return to the proper home/zero location. The wrong zero/home location seems to change too. Any ideas…?

@WilliamPaukert did you use the easel.com/setup program?

@Zach_Kaplan Yes, I went through the set up 3 or 4 times.

@Zach_Kaplan Thanks for the quick response Zach. This is a ll new to me. I have no idea how to access UGS or where it resides on my Mac. All of the Grbl code is new to me as well, so pardon the hand holding in advance…!!

No problem. UGS stands for Universal G Code sender. Technically you shouldn’t have to use it to get the X-Carve to work. I thought you might have changed the settings in there.

Aside from doing the Easel setup have you done anything else from a settings perspective?

@Zach_Kaplan Aside from giving input to Easel when prompted (bit size, material size, depth of cut, spindle on, etc) I haven’t changed or adjusted anything…I don’t really know how to… :smile:

OK. Hang tight until tomorrow then. I emailed our engineering teams. It sounds like you might be having the same problem as @AlanDyke and I think in both cases it is a software, firmware, or settings issue.

@WilliamPaukert You may have a work offset loaded.

Can you download the Universal G-Code sender and run the $$ command and paste the output? And can you take a screenshot of the UGS screen once you connect to the X-carve?

You can download it at https://github.com/winder/Universal-G-Code-Sender

1 Like

Will do. Thanks for the advice…!!

@Johanen…Ok. So I’ve downloaded UGS. I’m trying to get it to talk to my X Carve but not sure how. The USB cable is connected to my Mac and the Arduino. In the UGS window under connection I see the drop down menu for ports–the are options for bluetooth, wireless and usb modem. I’ve tried choosing each of them and then tried the x/y/z move buttons under machine control, but no response. I’ve entered the “sudo mkdir /var/lock sudo chmod 777 /var/lock” Terminal commands suggested for Mac’s and it says that the file exists, so I should be good to go there. Got no clue what to do next…!!

Have you checked to make sure your pots on the drivers are tur,ed up enough. I had the same problem whe, cutting it was going slow enough but when jogging the machine would lose steps. Just a thought

I’m not having trouble jogging the machine in Easel. It works great. All the shapes it cuts are perfect in size and dimension. The issue is that the placement of the what the machine cuts is wrong.

@WilliamPaukert hang tight. Our engineering team is looking into this. We believe it is a work offset issue.

@TaitLeswing do you think @WilliamPaukert is having the same issue we talked about for @AlanDyke

Hangin tight here…!! Sooo glad to have the support from you guys.

Yea when mine was doing it shape size was perfect it was only location

@Zach_Kaplan it’s likely.

@WilliamPaukert can you please try the following:

  1. Close all programs that might be trying to connect with your Arduino (Easel, Universal G Code Sender etc.)

  2. Open the Arduino IDE

  3. Go to File - Examples - EEPROM - eeprom_clear

  4. Make sure the number that this pink arrow is pointing to is 1024 and NOT 512

  1. Click the arrow in the top left of the IDE

  2. Once the sketch has uploaded close the IDE and open X Loader

  3. Upload the hex file, be sure the baud rate is set to 115200

  4. Close X loader and open Universal G Code Sender

  5. Type $$ and paste the results into this thread

1 Like

If you’re looking for the software:

Arduino IDE

Hex Uploader for Mac

@TaitLeswing After getting to step #4 above, here is what I see:

@WilliamPaukert great, you have the newest version of Arduino IDE and the new EEPROM clear program doesn’t need to be edited at all. Skip step 4 and continue.