[Solved!] X carve cutting the right shape, but in the wrong location

@TaitLeswing I got to step #5 and now I see this:

@WilliamPaukert try unplugging and reconnecting your Arduino and uploading the sketch again. Do this a couple of times if it doesn’t work the first time.

@TaitLeswing So I tried loading the sketch about 15 times and kept getting the error message. I tried both USB ports on my Mac, powered down and restarted the computer twice, unplugged the power to the Arduino twice and let it sit for a few minutes and I also tried a different USB cable…No luck.

@WilliamPaukert it may be that the IDE is looking for your Arduino on the wrong COM port. In the IDE go to tools - serial port and see if you have options to choose from.

@TaitLeswing Switching the port under tools worked. I’ve got Hex Uploader open. In step #7 above when you say to upload the Hex file, I click on “Upload a Hex file” a standard Mac directory opens up, but I don’t know what or where the Hex file is that I am trying to upload.

@WilliamPaukert here it is:

grbl0_9i_X_Carve_500mm_ACME (1).hex (80.3 KB)

@TaitLeswing Ok. When I click upload on the Hex file loader, am I supposed to see anything happen, because once I select the grbl_9i hex file and hit upload it just goes back to Hex uploader window, same as it was before I hit upload. I opened up UGS tried connecting through the USB modem ports, entered the $$ command but nothing. No machine control either. Also, it appears that the green lights on the Arduino are no longer on, but I’m pretty sure they were before…

@WilliamPaukert did you close the IDE before opening X Loader?

@TaitLeswing Yes, I did. I just tried the whole process again and still nothing in UGS.

@WilliamPaukert is the baud rate set at 115200 in X Loader?

Try redownloading the hex file from this wiki

@TaitLeswing Still didn’t work. I downloaded the Hex file. Opened Arduino app. Uploaded the eeprom_clear, assigned the correct port. All good, uploaded. Closed Arduino app. Opened Hex loader. Selected the correct port. Confirmed baud of 115200. Chose the Hex file you linked to above. Hit upload. No change in Hex uploader window. Close Hex uploader. Open UGS. Tried both USB ports. Confirmed baud at 38400. Tried $$ command. Tried machine control. Nothing.

@WilliamPaukert your baud rate in UGS should be 115200

@TaitLeswing Changed the baud to 115200. Still no change. No green lights on Arduino still.

@WilliamPaukert the LED not turning on is not a good sign, try pushing the reset button on the Arduino by the usb port.

@TaitLeswing …Ok. I mis-spoke. The small LED’s on the Arduino are on–but its the green LED’s on the G shield that are not on. the definitely were before. Easel does not see Gshield/Arduino either when going through the set up procedure.

Are you sure that what you think is the top of the machine isn’t the bottom, or what you think is the left side isn’t really the right? When you jog it an inch, is it going an inch in the direction you expect it to?

EDITED: I changed a couple of is to isn’t.

Positive. When it was working it jogged perfectly and in the proper direction. The shapes it did cut were the proper size and orientation on the workpiece, just not where they should be.

@WilliamPaukert Can you take a screenshot of hex uploader when you try to flash the hex file please?

@TaitLeswing I would, but now my USB port won’t show up or connect in any of the applications. Not in USG, not in the Arduino app, not in Easel, not in Hex loader.

@WilliamPaukert USB can be very frustrating, hang in there. Can you restart your computer with the Arduino unplugged, give your OS a minute after it opens up and then try connecting again?