Inventables Community Forum

UGSPlatform and ubuntu16.04

i feel super dumb asking this here but the rest of the Internet has not been able to answer me.

i have just moved over to Ubuntu (and i am still very much a noob at Ubuntu). so i have downloaded the UGSplatform app since i prefer it over the classic ugs(which does run),

however i do not know how to get the app to run. double clicking only opens the software code. i cannot figure out which command to run in terminal to make it work either.

was really hoping someone on here has some input for me, my x-carve has been standing for months due to computer issues and I’m desperate to get carving again! please help.

go to ugs platform folder you downloaded.
then bin folder
right click, open terminal
then paste this code

./ugsplatform

Make sure Java 8 is installed as well.

YESS YESS Yesss!!! thank you. its now loading!! thank so much!

2 Likes

Just saw this and make me smile.

Glad you made the conversion without to much issue.

you will enjoy Linux once you get the hang of it.

I hope you also get Easel Local to work without issue. so you can use the Easel software online.

yep im in with ubuntu th learning curve is immense though!! now trying to learn how to setup a serial port. its like learing to speak chinese. but anything is do-able! tody ha been leps and bounds !! :grin: i’dlike to use easel too!

then check this out

and feel free to ask questions as needed, I have found that everyone is very helpful in making this work.

sigh, ive just read through that… a pie is currntly not on the cards for me… i’m going to have get linux to see my machine via a local usb. i’m so used t windows that this is making me feel completely dumb. lol. ugs is currently not seeing my machine. i can see the usb plugged in in terminal but need to figure out what to do with that info…:exploding_head: but i’ll get there, ugly but not scared

the same driver that runs on the Pi also works with Ubuntu.

I use Ubuntu on my desktop and have a Pi connected on the X-Carve. I have loaded the driver on Ubuntu and run it. it seemed to run without issue.

keep trying. and read about the USB port thing most of that is automatic nowadays.

just a quick thanks again! im up with ugsplatform and easel is running and i did my first carve in months tonight!!! YAY!!have a great new year this weekend everyone!!!

Hey guys, I’m new to x carve… Just finished setting up the maching ,test carving, and my first file! Everything runes perfect! Here’s my question,
Do I have to be online to run Easel?
My situation is that it’s set up in my Guitar shop, away from my Wifi. I got a wifi signal booster but it didn’t work… I ran 150 foot of Cat 6 cable, but don’t want it laying in the yard…(till the ground thaws, so it can be buried)…

Will
Detroit, Mi.

Short answer: no

Long Answer: sometimes, if you want to log-in you need a connection. to open a file you need to be logged in and connected. but to carve after you have your file loaded you do not. if you make changes to your file and want them saved you need a connection and logged in to save.

so connect, log-in, open file and then no internet needed after that to use Easel as a sender… I have heard of some using a cell phone connection to do this in a remote area as the data needed to log-in is not that much.

I tried this too and it didn’t work for me
Any other ideas … I can only get the listing of that program …can’t get it to run tho …

@BertAmick are you using Ubuntu and if yes then what is the error listed in the console after you enter the command ./ugsplatform ?

If you get command not found did you make sure the file ugsplatform is executable?

I get no error , it is like I just opened the file …it lists that program file …
Since … I have tried to set the properties to run on Java 8, which is the installed Java version. I have also put a .java behind the file name to get it to run. It is like it is just dead to java.

I have the UGS file located on the Desktop , trying to run from there…and Yes Ubuntu

Do I enter the ./ugsplatform in Terminal ?

When entering ./ugsplatform in Term … I get a response that the file is not existing

When I installed the file in Desktop , I copied the ugs file to the Desktop then unzipped it there , which produced all the files … do I need to do an install there ? YUP , I am just getting used to the commands in Linux …used to do this back in tha days of Unix ,that’s been a while…

Okay:
if you have extracted the files from the compressed files note where you have placed them.

then open a terminal and open the directory where you extracted them to. ie cd. /home/user/Desktop/ugsplatform/bin

once in the binary folder (bin) for the program then execute the file ./ugsplatform

the ./ will look in the current folder
the file is ugsplatform

if all is well you will open the program if that fails what is the message.

more than likely the only thing that can go wrong at this point would be the file is not executable. but I do not want to give you that command unless it is needed, not that it is bad just not usually needed.