Y axis problems - solved-

Hello community,

I have times again a few problems with my X-Carve 1000 * 1000 mm.

  1. The x-Carve stops milling sometimes, sometimes in the middle of the milling process, and simply stops. It can not be controlled anymore.
    This has now happened several times. That is why I decided to transfer my workpieces directly via the G-Codesender. At the same time, I realized that the milling machine does not work exactly. And we are already on the second problem
  2. The x, y, and z axes work differently.
    X and Z axes work properly. But the Y-axis moves the triple section.
    For example: if I give the y-axis the command 1 mm drive, it drives 3 mm.
    The further I think that it moves also three times as fast.
    In addition, I will insert the log of the last milling in which the milling machine has stopped.
    Furthermore, the y-axis remains simply hanging on the command, for example 300 mm forward. However, this is not always the case.
    I do not know where the mistakes lie.
    The mistakes are guaranteed, but what mistakes are there?Fehlermeldung x-Carve.txt (4.0 KB)

I hope you can understand my problem or my english.
The current voltage of the y-axis I have already tried to change, unfortunately without success.

Sorry for my ignorance, hopefully they can help me.

Greetings Andre`

1 - can be due to electronically noise / power drop-out of your USB-port.
Shielded USB cable with ferrit core might help. A powered USB-hub can also cover the symptoms. (The actual cause can be difficult to pin point

2 - Triple the steps per mm in GRBL, look up how to edit GRBL- settings using the Easel Machine Inspector (CTRL+SHIFT+D)
During initial machine setup, what kind of rod did you select for the Z-axis? (and which one you got if any?)
(I dont have xcarve btw)

Thank you Haldor,
I really do not know what you mean.
Do you mean my positions in the machine inspector?

Is it possible?

$132=100.000 (z max travel, mm)
$131=790.000 (y max travel, mm)
$130=790.000 (x max travel, mm)
$122=50.000 (z accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$120=500.000 (x accel, mm/sec^2)
$112=500.000 (z max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$110=8000.000 (x max rate, mm/min)
$102=188.976 (z, step/mm)
$101=40.000 (y, step/mm)
$100=40.000 (x, step/mm)
$31=0. (rpm min)
$30=29000. (rpm max)
$27=1.000 (homing pull-off, mm)
$26=250 (homing debounce, msec)
$25=750.000 (homing seek, mm/min)
$24=25.000 (homing feed, mm/min)
$23=3 (homing dir invert mask:00000011)
$22=0 (homing cycle, bool)
$21=0 (hard limits, bool)
$20=0 (soft limits, bool)
$13=0 (report inches, bool)
$12=0.002 (arc tolerance, mm)
$11=0.020 (junction deviation, mm)
$10=115 (status report mask:01110011)
$6=0 (probe pin invert, bool)
$5=0 (limit pins invert, bool)
$4=0 (step enable invert, bool)
$3=3 (dir port invert mask:00000011)
$2=0 (step port invert mask:00000000)
$1=255 (step idle delay, msec)

If Y (I wrongfully read Z) moves 3x the intended distance you can change that by recalibrating the step value in software.

Check value at $101 which reads 40 (y, step/mm)
You can change this by typing “$101=120” and hit ENTER in the Machine Inspector dialogue window.

In your log file the error is “undefined feed rate”. The G1 G-code command needs to know how fast to move the machine and your G-code file has not set a feed rate prior to issuing the G1 command.

How did you generate your G-code and if not Easel, what post processor did you use?

Your grbl settings look normal. You do not need to change $101 as that is not your issue. You have some other problem with the Y axis.

Do you have the X-controller or some other control electronics?

Thank you in advance.
So now changed the settings. Unfortunately not quite with the desired success.
Enclosed 3 pictures with the changes.
Each time 1 mm step is given as command.
Picture 1.Machine is at zero / 0.
Figure 2. Path with setting 120
Figure 3. Path with original setting 40

If I do not answer later, I’ll do it tomorrow. With us it is already 22.48 pm. And I have to get up early tomorrow morning.
Thanks anyway for your help.

Greetings Andre`

Hello Larry,
I’ve used the Vectric Postprocessors for Aspire.
And I bought this package X-Carve Arduino / gShield Motion Controller Kit - 30574-02.

Thank you

Firmware Grbl 1.0c
Easel Driver 0.33

Check the micro-stepping headers on the gShield. There should be a jumper on the Z axis, but no jumpers on X or Y.

Try these post processors with Aspire:

X_Carve_inch.pp (3.9 KB)
X_Carve_mm.pp (3.9 KB)

Is that correct?


Read through this material and see if that helps:

Thank you first your two.
I look tomorrow times if what changes with the new postprocessors and work me times through the other thread.

Now first good night and thanks again.

Greetings Andre`


First of all, use a calibration file in Easel only so you know your baseline is good, then dive into the post processing issue that may be the cause of your problems.

Hello everyone,
I have now dealt with the article.
Furthermore, I have made the Y-axis cable new.
I also tried to adjust the calibration of the motors (Y axis).
But either he does not move at all. Or he moves too fast and stops and grots in the middle.
I hang out a small video to understand the problem.
The command was 100 mm.
I hope you understand what I mean.
How can I reduce the speed of the Y axis?
I have no way out.
Thanks in advance for your help.

Greetings from Germany.X-Carve Speed.3gp (3.9 MB)

As a temporary test do the following:

At the gShield, disconnect the X axis wires from the gShield.

Move the Y axis wires to the X axis terminal.

Connect the X axis wires to the Y axis terminal.

Run your test.

With it wired this way does the problem remain on the Y axis or does the problem move to the X axis?

Yes Larry now I have the problem with the X axis

Now I can also measure the way better.
Instead of 100 mm, it travels 400 mm.

If the problem appear with a known good motor/axis then the error is most likely located to the gshield / motor driver.
Any distance error that is off by a factor of 2/4/8 etc is most likely a micro step issue.
100mm command => 400mm travel = a factor of 4 => GShield set to incorrect step setting?

See this link:

@AndreNiemand We already checked the micro-stepping.

Your gShield is bad. You need to get a replacement.

Larry, now you’ve messed my day.