I have assembled my 750 mm x-carve. Went through the set up, but when I got to the Z probe things have not went well. I plugged it in, GOOD. Put the clip on GOOD but I touch the probe nothing happens. I called Inventables they sent me a new probe but the same thing is happening. I checked all the wiring GOOD. I have no idea what to do now SUGGESTIONS PLEASE!!!

Are you attaching it to the bit or the collet?

My stock Dewalt collet is not conductive enough for probing. That might be your issue.

I was thinking the paint was to thick and needed skuffed up a bit.


bought the upgraded collet

were it is mounted

I have had similar issues. But it seems it is sporadic. I have found that if I disconnect it and turn it a quarter turn that it works itself out.

I had the same trouble and sanded 1 side of it off so the paint was not so bad. The paint is so heavy on it the magnet is not making good enough contact. It won’t hurt anything try it and see if it helps.

will try that

1 Like

k Thanks wont hurt

His wiring is fine. Read his post. Easel sees that he connects the probe (changes from a closed connection to an open). It just doesn’t see it change when he touches the bit. It’s a conductivity issue at the router side.

Have you tried just touching the probe plate directly to the collet clip/magnet/whatever? Make sure the socket on the Xcarriage is fully tightened and you’re fully inserting the probe plug (mine makes an audible click).

My Zprobe just crapped out the other day, the metal inside of the plug broke from repeated use. Luckily, I had Charlies on hand.

I would like to thank everyone for the responses. I still cant figure it out. Disassembled the controller twice to make sure all wiring was correct. All was correct. Triple checked every thing. All is correct. I am lost. Not sure what’s going on. I sanded all the paint off where the probe hooks up, didn’t work. Don’t know what else to do except call Inventables. Once I find out what’s wrong I will pass it on to everyone.


Take a look at your plug.
I had probing issues last year and this is what I eventually found.
A dead short in the plug.
I straightened out the wiring and it has worked perfectly ever since.

My issue were the ribbon cables, pushed them down all the way and reassembled the controller. Works!

1 Like

I am having the same issue. I have a mutlimeter on hand and when i touch to the plate and collet it is showing continuity. Anyone have any ideas?

I thought the x controller didn’t use grbl. this might be showing how very little i know.

In Machine Inspector GRBL version and Easel Local version will appear.
Entering “$$” in the Machine Inspector panel will prompt the GRBL readout, what is your $10 set to?

Maybe this will help.