Inventables Community Forum

Easel Local for Linux?

if you read this post you will find that the package you require has to be built from scratch. It is not hard to do and works great.

this would depend on what version of Linux and what package manager you are using. but it will be contained in your package manager log files. But from your previous statement on this post I would feel safe to say that your error would be no requirements found to complete the install. Linux files are based on a X86 architecture and your raspberry Pi is based on an ARM architecture.

If you just want to skip to the most important parts here is where I would start

Please note that the easel driver has been updated to version 0.3.15. your scrpt needs and update

My driver is open source and I’m always happy to accept pull requests for updates/improvements.

Anyway, I’ve altered it to no longer need to know the version number and just pull the source of the download page, then grab the package which should be the latest version so it should now dynamically download the latest (unless Inventables changes the page/filename structure).

2 Likes

Hi, i am trying to use these commands to install the easel driver on my Pi4, just using it as a standalone PC so i can design on my laptop inside then fire up the Pi and carve directly from Easel in the workshop, i am very new and have little experience with entering Commands, not sure if i am doing it correctly just to clear a few things up when you have && (in red) at the end of a command does this need to be entered at the end of the command or left out? also im guessing when their is a | (in red) this is just separating two commands that need to be entered separately. Thanks

Either download the easel-driver.sh and run sh easel-driver.sh or just copy and paste the entire block of code as a single command (keep the &&'s – I added those so you can copy paste all at once instead of line by line)

2 Likes

Ah yes i have copied over the full script which seems to have installed everything correctly. but still cant get my controller to connect, i did have a line at the end that said-

cp: cannot stat ‘arduino-flash-tools/tools_darwin/avrdude/etc/avrdude.conf’: No such file or directory

Also when i run screen -r easel i get the message 'There is no screen to be resumed matching easel so tried a few things as stated in previous posts when i enter

iris.js i get- bash: iris.js: command not found

pwd i get- /home/pi/easel-driver

i ran cd easel-driver then ran just ‘screen’ i got a full screen of info about licensing etc.

Not sure where im going wrong

Looks like they changed the path of avrdude.conf. I’ve just updated the github to work on the latest version, let me know how that works for you now: https://github.com/samyk/easel-driver

Deleted everything I had and re entered the new commands into terminal all appeared to load correctly. Added the command to start driver on boot, also changed the auto port enumeration and have nothing.

Tried running ‘screen r-easel’ and got nothing

Not sure why it isn’t recognising the router.

It’s screen -r easel, not r-easel. Double check that. Also, please output what happens when you run crontab -l

If the screen doesn’t work, also output (do a full copy and paste of the command and output): cd ~/easel-driver && /usr/bin/screen -dmS easel node iris.js

Thanks

No worries I’m away from the raspberry at the moment but will try when I get back. Thanks for your help

So I had a go with the commands and this is what I got

Also this is my serial driver does it look ok?

Edit- so my knowledge of linux is very limited, thought the port you had was a generic thing but i found the correct one my router is using by running ls /dev/tty and got /dev/ttyACM0 so used that but still unable to get the carve tab to go green in easel.

Anyone able to help?

What does screen -r output? What about cd ~/easel-driver && node iris.js?

Tried both and got this

Ahh that’s very helpful, try npm install socket.io then cd ~/easel-driver && node iris.js again and paste output please

I’ve uploaded a new version @LukeGunnell that may help – also automates the add-to-startup process

Is there a video of someone doing this from start to finish? I’ve been trying to connect a raspberry pi 4 to my x-carve using your method to no avail. Or is there a link to a step by step for dummies lol.

Hi @HeathJaridLacy can you send a screenshot of what happens when you run cd ~/easel-driver && node iris.js ? Do you have gchat? Or shoot me some contact info and I can try to help you figure it out.

1 Like