Setup on Mac hanging after confirming settings

I’ve just finished my 1000mm build and when I try to confirm my settings for the machine setup, my computer just hangs at “Plug in your USB and turn on the machine.”

Macbook Pro with OSX 10.9.5 (also tried my wife’s Pro which is running 10.10.5)
Same results with Chrome (latest version), Firefox 40.0.3 & Safari 7.1.8
Using stock USB from Inventables
USB sees Arduino Uno in System Report
G-shield has 3 green + 1 blue LED
I’ve rebooted & reinstalled Easel Local.

When I turn on the power supply for the X-Carve, I do feel the machine try to move VERY slightly - enough where I can tell that power is going to it. And the green lights light up when I move the gantry around with the power off.

I’ll be using a 611 with it but I don’t have it on the machine yet - for setup purposes, does it matter what the spindle switch is set to? I’m assuming not, and I feel like i’ve tried it in ever setting.

I’ve followed a bunch of the suggestions in this thread, but no luck. (having computer booted up before connecting, shutting down software, etc) I can generate & export g-code from Easel, but when I click Carve, it says that it can’t find my X-Carve. All electronics were stock with the X-Carve.

I’m aware that it seems like there’s no silver bullet fix for this and that I’m not the only one. Going to see if I can figure out UGS so I can get this thing off of our kitchen table and to it’s permanent home so I can get my wife off my back, but I’d love to be able to use Easel since a lot of what I’ll be doing will be VERY Easel-friendly!

All of my suggestions are in the thread you mentioned. One rare possibility is that your connection between G-shield and Arduino isn’t complete. Make sure the pins line up accurately.

Changing USB cable

It’s also entirely possible the g-shield or arduino is defective. I don’t know how to test for that, but trying UGC or chilipeppr might give some ideas if you have the same problem there.

If my g-shield/arduino connection was out of alignment, would the green lights light up as-expected when the machine is getting moved around?

Where does GRBL live? On the Arduino? Or on the G-Shield? I installed Universal G-Code Sender and when I connect to the machine using the fastest baud setting, all of the machine control buttons become active but then I get a lot of messages saying GRBL hasn’t finished booting when I try using any of those buttons. (I’ve tried both UGC 1.8 and 2.0)

Mike, have you tried ChiliPeppr? and then once that’s loaded, there’s a download link to Serial Port JSON Server in the lower right corner. Run that and it should show your serial ports. Then connect to localhost in ChiliPeppr and it’ll show you your serial ports. Connect to your Grbl device and see if it acts the same as UGS or Easel. Make sure you disconnect from UGS and from Easel before you try to connect from ChiliPeppr because they lock the serial port.

Not sure what I’m looking at in Chilipeppr.

I see “Serial Port JSON Server Disconnected”. When I try refreshing the JSON I get errors saying something like not connected to the serial port on the JSON server. I don’t see any sort of a download link anywhere.

Oh, click the large downward pointing arrow to expand that widget. For some reason that widget is starting in “collapsed” mode. The arrow I’m talking about is

Then you’ll see a tab with download links. Download SPJS for your Mac. Then run it. It will run in a terminal window and spit out a bunch of text telling you what your serial ports are.

Then go back to ChiliPeppr and connect to your localhost, which is you essentially connecting your browser to the Serial Port JSON Server.

Then connect to the appropriate serial port from the list and you should now be ready to send Gcode.

Mike I went through this exercise last week with Chillipeppr.

Scroll down this thread and follow the brilliant advice given by Sketch42

1 Like

I’ve connected to JSON in Chililippr, and I’m in the GRBL workspace but it says my state is offline. Also, the other screenshots I’ve seen showed port list with 411 in the modem name in the port list, but mine is 131 - does that mean anything odd?

I went through Sketch’s advice in your thread, @RobertMatusiewicz, but apparently I’m still missing something…

Also, I went into the Axes menu and it says “Tried to send a serial port message, but there is no port selected.”

Turns out I had a few weird things going on. The biggest being that GRBL wasn’t on my Arduino. I called tech support and they knocked it out of the park. Watching my machine run right now (but without the 611 installed yet).

1 Like

I experienced exactly the same symptoms but determined the Arduino and GRBL were fine. Seeing the comments about Mac problems I loaded the drivers and tried a Windows 7 machine I have and it worked perfectly. Curious to hear what the tech team says - all of my Macs run El Capitan and the two I tried did not work.

El Capitan is having problems connecting to a lot of Arduinos… I have a feeling that this will be fixed, but hopefully it is before El Capitan is out of beta.

You can see others having issues with their Arduino here:

As well as a lot of other places…

I wonder, @BarrySchuler, if you might try the command listed here and see if it helps El Cap. see your Arduino…

but read his warnings first:

Just a note, I’m going to start closing these threads when the original poster has posted a solution. It can be very hard to keep track of issues if people are always responding to the bottom of an unrelated thread.

For posterity: