Sometimes paths aren't showing up to carve from a DXF or SVG import

https://easel.inventables.com/projects/1FzceAFD27AhtqeC31ghyg

Does anyone know what’s going on here? I know dxf and svg can be touchy, but there has to be some kind of workaround.

I make these files in adobe illustrator. I’ve tried importing them into inkscape, even affinity designer and reexporting.

I make these kinds of files all the time for vinyl plotting and other flatbed routers. Is there any way possible to get this data to open reliably in Easel? Sometimes when I’m dragging around elements, I can see the correct artwork render in the preview on the right side, but then it disappears again.

I should note that I’m trying to cut the outside line to the full depth of the material, and everything inside that 3/8" depth, single .25 router bit width.

midewest detox midewest detox.dxf (121.0 KB) one day at a time.dxf (184.7 KB) soberAF.dxf (119.4 KB)

Your bit size is to large. Try putting in a smaller bit or a vbit and see what you get. Easel will only cut as wide as what is showing and if you use a bit that is larger then the lines it will not cut it.Also welcome to the forums and enjoy.

1 Like

Thanks for the insight. I am trying to use the “cut on shape path” feature though, not “clear out a pocket”

For these projects, I need all routing to be 1 single 1/4" bit wide so that I have a single channel. So even if I change my bit width, it has the same problem.

Did you try a vbit?

Can’t illustrator export an SVG? Can you post your original design file?

SVGs don’t retain size information, so they are useless to me since I can’t give my team a file that is sized properly to the job specs.

I did try svg anyway and it had the same issues, although slightly different lines appeared.

I tried different smaller bits and got the same result. I posted a link to the project you can see for yourself.

The DXFs are messy. Can you share the original file?

The adobe illustrator file? Sure. What about the dxf s make them “messy”? Files like this work on our other cncs without issue.

That is pretty wierd no matter what bit you put in it does not cut anything.

Yeah I think I’m just going to have to use a 3rd party CAM that can import dxfs properly. We use CamBam on another machine, maybe I can get it working for this one.

The remote access on my work PC is messed up for some reason but here’s a pdf:lit signs.pdf (410.4 KB)

When I export this file to a DXF and import into other CAMs we have it’s read just fine. Also all paths are visble when imported even in Easel, it’s just deciding not to cut them.

Zoom in really close on the S, for example. There are double lines and extra nodes. The M is two Ms stacked on each other. They need to be cleaned up if you want to use them as single line fonts.

From your PDF:

2 Likes

A double line may be the cause. Delete one on the toolpaths. Here is a video that shows the double tool path and how to correct it. https://youtu.be/kUTdFQAo81M

Did you find a solution? I’m having a similar problem with imported DXF text partially printing some letters. The image on the workspace is perfect, but the generated preview has missing parts of many letters.

That has always been my white whale! I have wasted so many hours chasing down a double line. One accidental cut/paste and it is g-code pandemonium!